IOS app (cannot use configurator) resolved


#1

I use the configurator for editing my yaml (Haasio on an rpi) files without issue on my mac/pc etc but when using the IOS app on my phone I only get a blank screen, can anyone point me in the right direction here as I am obviously missing something in my config


#2

Are you on your own network? is your HA server reachable from outside your network? If so; what solution do you use?
Are the other addons working in the app?


#3

I do not know if it has been tested on the iPhone with the app. You can file an issue here.

I know there is an open issue for Android that is a problem with the underlying Ace Editor.


#4

@Pippyn same on both internal/external network, HA server is reachable from outside my network using duckDNS/lets encrypt add-on all other admins work fine in the app.

@bosborne ah right that could be it however, I do seem to remember seeing a similar post and it being resolved but for the life of me I cannot find that post.


#5

I used to use the app in the same way (duckdns with ssl) and configurator worked fine. I now use a reverse proxy and configurator still works.
Did you forward the port in your router?


#6

I just tested on mine & it works fine. You need to forward the configurator port (default 3128) in addition to the Home Assistant one.


#7

Yep that did it, had forgotten to forward the port for configurator, thanks both!


#8

Sorry for the misdirection. I just had not tried in the app & my HA is going through some development so was unavailable to test.


#9

There are some known problems with ios and the configurator if you have the following enabled.

frontend:
  javascript_version: latest

Though I haven’t tested this as I use the yaml mode (classic way of lovelace).