iOS App configuration issue

Tags: #<Tag:0x00007f326d4a9560> #<Tag:0x00007f326d4a93a8> #<Tag:0x00007f326d4a91f0>

Hi Everyone,

I am having a strange issue. I cannot get the App to work unless I am in my home network. I have Nabu Casa and I can access HA via Safari but if I try the App I get a blank white screen. I have tried to look up a solution and found out that it should automatically connect via the cloud. I double checked and have remote control toggled on. Cloud connection status is connected.

I have my connection setting in the app configured as followed. Internal URL http://[myip]:8123 with SSID set to my network. External URL is blank. I have tried every combination I could think of between the two and get either a server error and blank screen or just a blank screen. I tried to put the Nabu Casa link in the external url section and that just gives me an error. I saw something that said make sure connect to cloud is toggled but I don’t have that option.

Any help is appreciated! Thanks All! I should mention I am brand new to all this. I might need an EILI5