iOS app with new auth - getting blank screen?


#1

So I’ve set up the new auth protocol. Legacy API password support is enabled. However, opening the app prompts me with the username and password login screen, and after I log in, it just shows me this blank screen:

Home Assistant 0.77.2
iOS v1.1.1
Auth details: https://developers.home-assistant.io/blog/2018/07/02/trying-new-auth.html


#2

Can I suggest an uninstall and reinstall of the app? I’ve only ever had to do this once but it helped me in a similar situation a few months back.


#3

Do you have 2fa auth turned on?


#4

I have the same issue on a ipad2 ios 9. In fact i can’t even load from a browser on this device. Could that be the issue? is there a workaround?


#5

Which iOS app version do you use?


#6

blackgold as in steelers fan?


#7

Last time I checked on the device there were no updates for my ios app but the version I had was from Sep 2017 I think. I will have to check at home on the ipad.


#8

I see. IIRC the official released version is not compatible with the new auth system, so you have to use the legacy one. Or you give the beta versino of the app (1.5.0) a spin. It is working pretty reliably for me at least and as far as I know they are pretty close to officialy releasing it.


#9

make sure you have the iOS section in your config,

# iOS Setup

ios:

Just like that, nothing else needed. then it should show up in the discovered section. Dont need to have the legacy setup either, well I dont, just click on your instance, then save, then done, and it should work.


#10

I think I’ve found a somewhat successful solution:

  1. Turn off wifi because it crashes the app when you go into settings screen
  2. Open HA on ios and go to settings
  3. Click on Validate and Save Connection Settings
  4. Allow it to try to connect
  5. If the username/passowrd prompt comes up, enter your info
  6. You should/might be set

#11

hello, did you solve that problem? i have the same issue except on a ipad mini i gen running ios 9. oll other device running a more recent ios are working, it used to work on that ipad but stopped working


#12

Nope I haven’t looked at again. My plan was to implement Tileboard when I get a chance but that is still on the back burner for now.


#13

I just tried the new iOS app on my ipad 2 last night and it worked great! It showed me my lovelace interface by default.


#14

Not for me, I still get groups.yaml loaded.