iOS Companion App Crashes at Startup

A few weeks ago I edited the exterior URL in the app configuration and I believe I may have had an error in the URL.
The app has crashed immediately on startup ever since.
Originally I was on iOS 14.6. I have since upgraded to the 14.7 beta, but the crashing persists. I tried every combination of deleting the HA app, reinstalling it and restart & hard reset of the device.
I even tried wiping the phone completely and restoring it from a backup. I have also deleted all the companion backup data from iCloud backup in case it was coming in to play somehow.
Nothing has worked.

Has this happened to anyone else?

I’m just speculating that the problem is related to my edit of the exterior URL, but the crashing began immediately so I think it’s a good bet.

Hi, there are two possibilities of resetting. Did you reset all (frontend and app)?

I haven’t reset the front end. I’m not clear on what that would require, but I’ll do some research.

And thanks for your reply :+1:t2:

Update on this issue:

Home Assistant 2021.7 released on July 7th no longer crashes at startup.
iOS version is iOS 15 beta (public beta 2 I believe)

The previous version of HA still crashed on beta 15, so the update to the app corrected the issue whatever it was.