iOS Components not loading under Settings

When looking in the iOS app’s Settings I see that the components under Status aren’t loaded, so things like location based triggers are hit and miss. Sometimes they work, sometimes they don’t

I've tried killing the app (double clicking the Home button to show the App Switcher, then swiping up to 'kill' the app), then launching it again, but that doesn't fix the problem. It also happens with my wife's iPhone.

If you look at the screenshot you’ll see under Status that the Home Assistant version is 0.32.2 whereas at the top it says

Is anyone else having this problem with the app, and does anyone know how to fix it?
Is it a known bug?

1 Like

What happens when you hit ‘save’?

Er… it refreshes and the components are now ticked!

…in my defence I saved URL and password a while ago when I first launched the app, saving them again isn’t something you’d think would fix it :sweat_smile:

I guess a ‘Refresh Components’ or ‘Reload Components’ button would be more intuitive.

For me, hitting the Save button turns those 3 crosses as ticked. But again if i kill and relaunch the app, i find them crosses again.
Location based triggers are since not consistent, and i need to update location manually by hitting the one shot location update.

Hi @Airpal,

Did you configured the location of you iOS device using the app? how did you did it, because in my case i don’t see anything.

Please can you explain me?


Manual location update is possible using button at the bottom-left corner.
This button is available when your location tracking is enabled in the app.

Hi @Airpal,

I have this button enabled, just when i click appears me a message error: “Location failed to update” Failes to send current localtion to server. The error was the operation coudn’t be completed (SwiftLocation.LocationError error 6.)

But in setting option iOS Component Loaded and Device Tracker Component Loaded are both with the “Ok”.

In the configuration.yaml file or device_tracker.yaml what i need to configure?


@garvarma Please check whether your ios location setting is ON for this app:
Settings > Privacy > Location Services > Home Assistant = Always

I have the exact same problem. It seems to be happening to me when sometimes there’s a time out when sending a location update. I open the app, there’s a alert about the time out, and the components are not loaded after that. I have Location Services at Always.

Seems like it may also happen with a Home Assistant restart.

Edit: Maybe not. I’ve tried to reproduce what I was seeing and had no luck.

Ok, the same here. With three iOS devices, it is not possible to track them. Same like the screenshot in the first post.

Before I have switched to https it worked sometimes, if the iOS devices auto-discovered the local instance of HA in the local network. A long time after starting HA. But without discovering the instance, connecting via FQDN, it does not work.

Some way to force the loading of the components on the server?

1 Like

Sam issue was solved after starting homekit in configuration.yaml
You just need to type: ‘homekit:’ and restart HA

1 Like

Hi, I still have the same issue using the Home Assistant 0.82.1. If I leave the HA iOS app in the background all three options iOS Component Loaded Device Tracker Component Loaded iOS notify Platform Loaded keep being checked off and then tracking works fine I do getting push notifications when I leave home or enter it.
But when I kill the app it stops sending updated to the HA server and no push info about my location is triggered. Then when I open it up again all three options in configuration are again unchecked so I need to hit Save button again.
I do allow HA iOS app to track device location Always (in iPhone settings).
Do you have the same?

I am also having this problem. Three X marks on two different phones

Ive only got device tracker checked, ios component and notifications no longer work. they did before. did something change?