iOS Location failed to update

I’m testing 1.5.0, if that makes a difference, but I’m convinced I’ve got some config setting wrong somewhere.

My phone doesn’t push any device tracker updates to the server - I get an error “Failed to send current location to server. The error was The operation couldn’t be completed (io.robbie.HomeAssistant error 400.)”

The logs on the server don’t seem to show anything useful, and my device doesn’t show up in known-devices.yaml.

Any ideas?

Can you show us your homeassistant: config?

I have the same problem om 1 phone. Another phone and ipad work fine.
Nothing gets logged in HA nor in the app

I’m having the same issue - about half the zone enters/leaves are not reported. It was also reported in the beta testing thread and those users all appear to use an iPhone 6s, which I happen to use as well. Which models do you have the issue on?

I too am having the same issue.

  • iPhone 8
  • Home Assistant 0.85.1 (hass.io rpi image)
  • App has all 3 ticks in config status
  • The payload screen in the App for any request in the history is always empty
  • Location services for the app are set to “Always”
  • In my HA instance, my device isn’t there as expected, but the sensors for my battery level etc are

configuration.yml:

homeassistant:
  name: Macadamia
  latitude: hidden
  longitude: hidden
  elevation: 12
  unit_system: metric
  time_zone: Australia/Brisbane
  customize: !include customize.yaml
frontend:
config:
updater:
discovery:
  enable:
    - homekit
conversation:
history:
logbook:
map:
sun:
ios:
lifx:
wemo:
weather:
  - platform: bom
    name: Weather
sensor:
  - platform: bom
    name: Weather
tts:
  - platform: google
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

.ios.conf:

    "devices": {
        "jc21-iPhone": {
            "app": {
                "buildNumber": 34,
                "bundleIdentifer": "io.robbie.HomeAssistant",
                "versionNumber": "1.5.0"
            },
            "battery": {
                "level": 88,
                "state": "Unplugged"
            },
            "device": {
                "localizedModel": "iPhone",
                "model": "iPhone",
                "name": "Jamie's iPhone",
                "permanentID": "B65B3098-hidden",
                "systemName": "iOS",
                "systemVersion": "12.1.3",
                "type": "iPhone 8"
            },
            "deviceId": "jc21-iPhone",
            "lastSeenAt": "2019-01-17T12:16:53.687595",
            "permissions": [
                "notifications",
                "location"
            ],
            "pushId": "31d5b515-hidden",
            "pushSounds": [],
            "pushToken": "This space intentionally left blank"
        }
    },
    "push": {}
}

I too had this problem.
I fixed my problem by turning off ALL update sources for Location in the app.
then made a new manual update, followed by enableing all settings agan.

  1. App settings/Location settings
    Turn off all “Update Sources”
    2 Go back and meke a maual update
    3 Restore settings again

My guess is that when a manual update is done for the first time and the sensor or any device tracker does not exist in HA something is going wrong

Hope it helps someone.

1 Like

I have the same issue and above post didn’t change anything:

  • iPhone 6s
  • hass.io 0.85.1 rpi3
  • hassOS 1.13
  • Supervisor 142

configuration.yaml:

# Show links to resources in log and frontend
#introduction:

# Enables the frontend
frontend:

lovelace:
  mode: yaml
# Enables configuration UI
config:
logger:
  default: info
# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
  api_password: !secret http_password
  base_url: https://autobahn.duckdns.org
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  server_port: 8123
  ip_ban_enabled: True
  login_attempts_threshold: 3
# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true
system_log:
  max_entries: 100
# Discover some devices automatically
# Ikea Trådfri
tradfri:
  host: 192.168.2.28
  allow_tradfri_groups: true
discovery:
#Tracks Devices
device_tracker:
# Show devices on WLAN Network through the Unifi Controller
  - platform: unifi
host: 192.168.2.20
port: 8443
site_id: default
username: !secret unifi_username
password: !secret unifi_password
verify_ssl: false
interval_seconds: 30
new_device_defaults:
  track_new_devices: false
ssid_filter: Autobahn

  - platform: bluetooth_tracker
interval_seconds: 15
consider_home: 150
track_new_devices: true
# Allows you to issue voice commands from the frontend in enabled browsers
conversation:



# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Adds zones to the map
zone:
  - name: Work
latitude: 55.534154
longitude: 9.468597
radius: 200
icon: mdi:worker

# Track the sun
sun:

# Sensors
sensor:
  # Weather prediction
  - platform: yr

# Text to speech
tts:
  - platform: google

# Cloud
cloud:

panel_iframe:
 configurator:
  title: IDE
  icon: mdi:code-braces
  url: https://autobahn.duckdns.org:8321
  
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

.ios.conf:

{
    "devices": {
        "ipad": {
            "app": {
                "buildNumber": 34,
                "bundleIdentifer": "io.robbie.HomeAssistant",
                "versionNumber": "1.5.0"
            },
            "battery": {
                "level": 100,
                "state": "Unplugged"
            },
            "device": {
                "localizedModel": "iPad",
                "model": "iPad",
                "name": "iPad",
                "permanentID": "3AC417D2-CA82-4676-8380-968683A06CFD",
                "systemName": "iOS",
                "systemVersion": "12.1.1",
                "type": "iPad 5"
            },
            "deviceId": "ipad",
            "lastSeenAt": "2019-01-21T13:47:06.828895",
            "permissions": [
                "notifications",
                "location"
            ],
            "pushId": "7ea41be1-f499-3d81-a921-ac42a5ef03e6",
            "pushSounds": [],
            "pushToken": "This space intentionally left blank"
        },
        "rasmusiphone ": {
            "app": {
                "buildNumber": 34,
                "bundleIdentifer": "io.robbie.HomeAssistant",
                "versionNumber": "1.5.0"
            },
            "battery": {
                "level": 78,
                "state": "Unplugged"
            },
            "device": {
                "localizedModel": "iPhone",
                "model": "iPhone",
                "name": "rasmusiphone",
                "permanentID": "53D4015B-9716-4747-B202-DE9E171575B8",
                "systemName": "iOS",
                "systemVersion": "12.1.2",
                "type": "iPhone 6s"
            },
            "deviceId": "rasmusiphone ",
            "lastSeenAt": "2019-01-21T14:33:55.078912",
            "permissions": [
                "notifications",
                "location"
            ],
            "pushId": "a06ad944-c3e1-38b7-bbc1-ca0cebfc8fa2",
            "pushSounds": [],
            "pushToken": "This space intentionally left blank"
        }
    },
    "push": {}
}

pictures from phone:

I have pictures of the mobile app settings and event log but only allowed to post one pic as new user, so let me know if you require these.




I’ve had the same problem and apparently it had something to do with the device_id.
I changed the “Device ID” in the ios App… et voilà, it worked again.

So in your .ios.conf you have "deviceId": "ipad", and in your iOS app you have “rasmusiphone” maybe that’s the solution.

6 Likes

I was wrong about my asumption but i think josip has a point. in both my cases i had a space in my IOS device ID . when I replaced the space with underscore it worked…

I had an issue when using an _ ,removed that and it worked (sorta, it keeps forgetting credentials)

Then we are down to just make a change of the Device ID. have you tried that @stockler?

Initially, it did not work with rasmus-iphone so i change it to rasmusiphone from reading another issue ticket.
I now realize that in the ios.conf my phone is named “deviceId”: "rasmusiphone " notice the whitepsace at the end.
I then changed my device id to rasmus_iphone and it now shows correctly and actually works for now.
I’m not sure if this is an error in the app or i made a mistake.

1 Like

Same issue - Had to remove a ‘-’ from my deviceid,

thank you

my problem was not exactly the same:
my phones autocorrect added a space after the device ID but did not show in the app
shame on me :wink:

thx

1 Like

Weird. I had space in the Device ID and it wasn’t working. Replaced it with “_” and it started to work.

Yeah! Worked: removed “-” from deviceId :slight_smile:

I cannot find .ios.conf in any folder either hidden or visible. Tried enable and disabling Update Sources which didn’t help. Device name is just the default ‘IPhone’.