IOS mobile app geofence

On the IOS HA mobile app, when I go to (Settings—>Companion app—>Location—>Location). I see a geofence that is not centered over my house. As a matter of fact, my house is not even in it. When I walk through the fence, my iPhone’s presence changes correctly, but since my house is outside the fence I have problems. I see no way to set a new geofence center and radius in the app. Both are grayed out so I can’t change the coordinate or radius. What am I missing? Is there something in the app I have overlooked?

Did you define your location in configuration.yaml?

  name: !secret name
  latitude: !secret home_lat
  longitude: !secret home_long
  elevation: 0 # 115
  unit_system: metric
  currency: AUD
  country: AU
  time_zone: !secret home_time_zone

If so, that is where you need to change it.

No I haven’t, thank you I will try that. I wonder how it got the original coordinates in the 1st place? What ever did it should have a button to rerun it. Thanks again.

Usually you set your home location during onboarding right after installation.

If you do use the YAML config then the Settings → General page will be disabled.

Try using a web browser to go to that menu first.

Thank you both. I added the lat/log to config file and it worked. I then went into Settings>System>General and sure enough it was grayed out, but look what I found!