iOS Mobile_app lost name for unknown reason - HA confused and cannot notify anymore

I have a lot of automations using the 4 iPhones in our household. A day ago I noticed mine was not being called ‘mobile_app_iphone_aldo’ but is now ‘mobile_app_iphone’ in HA. I do not know why…

As I have a LOT of automatons that now all break I tried renaming it back. I renamed the device under the “mobile app” integration, and had it update all entities. When I look in home assistant under devices and entities its all called as it was before (with the _aldo part).
But somehow in automatons (in HA and mainly Node-RED) they are still failing. Node-RED indicates there is no ‘mobile_app_iphone_aldo’ but there is a ‘mobile_app_iphone’.

As I am not really in the mood to go over and fix all my automations (and the name ‘iphone’ isn’t very descriptive) what am I missing? I somehow think it may have to do with iOS16 I updated too? All other devices are still named as they where despite also upgrading. And my device in iOS itself is still named “iPhone Aldo”. What am I missing?

Answering my own question (sort off):

Within the iOS version of the app go to Settings → Companion App → [Server name] → Device Name
The name was somehow empty, added it again.

Didn’t really fix it unfortunately. All automations work again without any errors. But they don’t actually reach the device (i.e. a notification is now send out again, it just doesn’t show). And in my dashboard it wasn’t working either as entities still seem to be named just ‘iphone’ (I renamed them one by one manually). Notifications just seem to end up in a black-hole however. This is rather infuriating :rage:

I had the same issue. I wasn’t sure if it was due to the latest Home Assistant update or the lasted iOS 16 update.

I had to update Home Assistant after the name change and it took a few minutes for the notifications to start working again.

1 Like

Glad to hear I am not the only one. Sadly for me so far no notifications actually getting to my phone after some time passing (and various reboots). Oddly enough I noticed Node-RED is still showing ‘iphone’ next to ‘iphone_aldo’. While that first one really does not exist anywhere anymore from what I can see. It also doesn’t reach my phone trying that one.

Perhaps it needs more time. I am a bit out of ideas :frowning:

Answering myself again. It took longer then that you @Jtmoore81 experianced. But today I got in all notifications that didn’t show yesterday-evening and now all are coming in again also. Somewhere something was delayed.

For completion sake:
For unknown reasons the name of my own iphone (which is NOT ‘iphone’) is being auto detected by the HA iOS app as ‘iphone’ if not overwriten in the app under ‘Device name’. This was not the case before, where it had the name of my actual iphone in iOS. Causing all automation to break depended on Mobile_app_[deviceid].

Other phones in our home the iOS app does see the actual name of the phone when you do not enter any device name in the iOS app. So the problem seems to be iOS app related, not HA. Somehow not detecting the actual name of the device.

I took the following steps to fix it:

  1. iOS app: Settings → Companion App → [Server name] → Device Name → Manually entered the correct device name.
  2. HA: Manually renamed the device back to the correct name
  3. HA: renamed all entities manually for this phone one by one.
    (One would asume step 1 would mean step 2 and 3 would not be needed and with step 2 that 3 would not be needed. But while device and entities has been changed to ‘iphone’ it didn’t not revert them back automatically with me)
  • At this stage nomore errors from automations but notifications did not arrive-
  1. wait patiently - in my case about 8 hours (i.e. did this in the evening, next morning when I woke up it worked again).

This is a well documented issue caused by ios16 changes:

1 Like