Ios notifications issue

I am new to HA so I may be overlooking something obvious but I am trying to create a test action that sends a notification to my iPad.

alias: New Automation
description: ''
  - platform: time
    at: '11:41'
condition: []
  - service: notify.mobile_app_ipad_pro_3
      message: Hello World!
mode: single

When I run it, nothing happens, no notification on the iPad and no error msg.

Please have a look here-

Make sure you “Allow Notification” from your iOS setting.

Revadak from other thread said “I removed the app from the phone and re-installed it.
During initialization it asks to allow push notifications. During the first time installation I didn’t allow this. No idea how to undo that, but at least the re-install->allowing it worked.”

Have you tried restarting the iPhone?
With mine, notifications all of a sudden stop working, but start working again after an IPhone restart…
so far I haven’t figured out why :thinking:

Do you see the sensors from the mobile app in Home Assistant? Sometimes it also helps removing the mobile app integration and deleting the app on the phone and start from scratch.

I think it was probably rebooting the iPad that fixed it. Working now.

maybe this is easier?

@aceindy Thanks. I did not try that but I will keep it in mind should the notifications fail again.

I just wonder if that is just a faster solution then restarting… or a more permanent.
This problem is, I won’t find out it stopped until I try…

seems it is related to a bug, which is reported allready