IOS Notifications Not working

I don’t know what happened but I can no longer send notification to my iphone. I’m running Core 2024.4.3 in a Proxmox 8 VM and IOS 17.4.1.
I’ve tried restoring a backup of my Proxmox home assistant VM, debug/reset in the ios app, deleted the IOS app and reinstalled it.

Not sure what else to do?

Verify the service your sending notification to matches the name in iOS settings >> general >> about >> name

Service will be notify.mobile_app_name

Check for errors in logs

Look at trace in automation used to send notifications

Can’t find iOS settings >> general >> about >> name. Is that in the mobile app or HA itself?
I did find this error in the log file but don’t what it means.

Logger: homeassistant.components.mobile_app.notify
Source: components/mobile_app/
integration: Mobile App (documentation, issues)
First occurred: April 19, 2024 at 8:49:26 PM (1 occurrences)
Last logged: April 19, 2024 at 8:49:26 PM

Requested entity was not found. This message is generated externally to Home Assistant.

Name is in iPhone settings. Not app or HA. The phone itself

Notify service can separately be found in dev tools of HA

By the error I would guess the wrong service is called or the service does not exist

If I notify all phones my wife’s phone works but mine does not. Is there a way to wipe my phone info in HA and start over?
I tried to delete all the reference to the IP addresss my phone is using in the security tab, and deleted the service in the mobile app and logged back in. Rebooted both the phone and HA without success.

HA app >> settings >> companion app >> notifications

You can first try disable notifications. Then reboot HA and verify the notification service for your phone does not exist (did you ever verify ithe notification service for your phone existed? Sending to all phone only work if phone has notification service registered in HA)

After disabling notifications and rebooting, reenable the notifications and verify the notification service for your phone appears in HA. You shouldn’t need to reboot for this to work but if it doesn’t show maybe give reboot a try.

You need to verify the service is present then not present after disabling. If it’s not present at start or is not removed after being disabled on phone there is other issue.

Not sure how you verify the notification service for my phone. The method I use is to call the service mobile_app_nameof_iphone in the services tab of the developer tools.

I went to the notification area of the ha app

Then reboot HA and they re enable the allow notifications option and reboot HA again for good measure

I then send a notification to my phone and it doesn’t work.

Yes this

Does it match your phone name?
Was it removed after you disable notification in Ha app?

Another person had notified trouble and fixed by adding to existing as DNS but I still suspect it was coincidence.

Honestly if service is registered it will work. Device Push ID is likely registered in file somewhere in .secrets I think so you can manually remove you phone there maybe. You can also try [reset] button in notification section of app where you previously disable notifications to create new push id. This is is likely registered in that file and should match current id showing in app. That should be checked.

I will verify this and let you know file location

Yes it does

No the notification is still there in the Develop Tools Service tab

I checked and that is normal

Only thing I got is you may try to reset push ID in HA App
Fully delete app from phone, make sure data is removed . reboot phone. reinstall app. Test.

I’ve tried both options and still don’t get any notification on the iphone. Notification is enabled on the phone

Did you restart HA server after?

Did you force quit app or reboot phone after?

What is shown when you select “rate limit” in HA APP?

Yes I’ve rebooted both the phone and HA after each step.
Rate Limits 500 after sending a notification to the iphone in the developer tools/Services

As a test I turned off my home assistant VM in proxmox and spun up a new HA instance from scratch using haos_ova-12.1.qcow2. Deleted the HA app from my ipad mini. After creating a new user and rebooting HA I installed the HA app on the ipad. HA recognized the ipad mini but still would not send notifications to it. I tried to reset the Push ID and reboot both ipad mini and HA. Still no notification. Something must be embeded in the ios device that I can’t remove by deleting the app and it’s data and reinstalling the HA app

was it recently updated?

are you receiving other notifications to device? maybe factory reset and restore it

I’m so sorry to have wasted your time. Turns out my phone was on do not disturb and that setting was shared with all my other ios devices.

Hilarious but good info. I thougt it would only silence them and definitely didn’t know it was shared across devices

1 Like

Nobody thought of resetting the push id on the notifications on ha companion app ( all the way on the bottom) :thinking:

That is actually what the reset is for, to reset the push id :wink:

Did that multiple times.