iOS: ObjectMapper failed to serialize response

I have the latest HA running along with nginx reverse proxy. Clients on the internal network can get to HA just fine, but if I use the iOS HA app and it scans for the HA server, it gives me this error:

Unknown error: The operation couldn’t be completed. ObjectMapper failed to serialize response

I would prefer to use the HA app itself instead of just using Safari on these old iOS 10 iPads that I have mounted to the walls. This only seems to happen on the older iOS 10 devices. Current iOS 15 does not have this problem.

Any idea what could be causing this to happen? I don’t even know where to start. Thanks for any tips anyone may have for me.


I am having the same issue as well with iOS 10.3.3. Running on a iPad 4th gen
Home assistant: core-2022.2.9
It seems to be working on iOS 15.1 on a iPhone 11 just fine.
I am assuming this is due to the older version of the app that is required for iOS 10.x

I had to resort to using Safari on these devices but I wish I could get something that had a way to hide the tabs and such at the top. That’s why I liked the app so much.

Same problem. Did work good until this month. IOS 022022 app update the problem?

I tried the latest client and it did the same thing. I wish I could get this figured out.

Yup. Also seeing this issue with traefik reverse proxy

Exact same problem on my side, iPad iOS 10. Did anyone figured out anything?

Not that I’m aware of. I’m using the angina Reverse proxy. I wonder if it’s because of that?

Same problem. Anyone acknowledged this is an issue and being investigated?

About the same issue here, only difference is that i have also tried without proxy so just directly connecting to port 8123 over http.

Short chronology

  1. running 2022.6.4 version of HA on Synology VM (just for the record, shouldnt matter as per below)
  2. connecting via browser works, from pc and also from iphone 5
  3. IOS app on Iphone 12 (IOS 15.5) works perfect :slight_smile:
  4. Iphone 7 (also IOS 15.5) as well
  5. My just revived Iphone 5 with latest possible IOS version 10.3.4 (intended to use as mini dashboard) installs latest IOS HA App 2022.3
  6. At first startup App find local HA instance but when trying to connect (before login screen) stops with mentioned error (Objectmapper failed to serialize response)

I would actually expect that apple automatically downloads a compatible version, Altough it asks for that with a pop-up i am getting 2022.3 (step 5) which is the same on my iphone 12.

Guess such an issue is not so high on the list though as the years pass by everyone has some old phone laying around

I can recall this ObjectMapper from a iOS development project which is part of the pod package AlamofireObjectMapper. It seem that requires an update in HomeAssistant companion app by the App developer to resolve this issue.

They may not be aware of this issue, because this error is not mentioned in Errors | Home Assistant Companion Docs

Perhaps multiple submissions of this issue could help in resolution from the App developers.

1 Like

This is still a problem for me for many months now. Using CloudFlared add-on which works fine with android and browser.

I’m also stuck on this… Is there any workaround/fix for this?

Any updates on this issue? I have an older iPad in a iRoom wall mount specifically designed for this generation iPad. I’d like to use the native app but i am having to resort to safari for this which is less than ideal.