iOS Pinch to Zoom Removed?

I recently noticed that pinch to zoom on the iOS when using a lovelace picture element does not work when I updated from Version: core-2021.2.3 to Version:core-2021.3.2. Is anyone aware of what changed this functionality? Any chance it was a bug that the ability was removed and that it will be added back in or was the removal on purpose? (I did downgrade back to core-2021.2.3 and the functionality is back).

1 Like

Pinch to zoom was intentionally removed from the frontend in 2021.3 as it caused some issues/complaints.

Although it’s no longer a standard behavior, a feature was added to the iOS app under App Configuration -> General -> Pinch to Zoom so you can re-enable this if you’d like.

@SeanM Thanks for the information. Happy to hear it is still an option. I went to “App Configuration” --> “General” and I don’t see a Pinch to Zoom. I see Device Name, App Icon, Open Links In, Remember Last Page and Page Zoom. If I go into Page Zoom I just get a list of %'s (from 50% to 200%) but no enabling pinch to zoom.

It’s on that same page under page zoom. If you’re not seeing it there, you’re likely on an older version of the app.

The app update with pinch to zoom was just released a day or two ago, so iOS might not have automatically downloaded it yet. If you open the App Store app, it should be available in there and you can just manually press the Update button.

Thanks! That was the issue!

Edit: Actually that seemed to work on the iPhone, but when I updated the iPad I still don’t get the option. I assume that makes no sense as the app is the same between the two correct?

Yes, it’s a universal app, so same thing on iPhone and iPad. Just tested on my iPad and it works, so I’m guessing the app didn’t properly update for you for whatever reason.

The version number in App Configuration -> About (top left corner) should say 2021.3 (2021.77). From that same screen you can also tap the “Join Beta” link if you want to try features like this earlier.

If you’re still not seeing it, you can file a bug report on GitHub.


I also didn’t have that option on my iPhone. Went to the App Store and had several other apps showing with updates. I updated those and several hours later checked again and still no offer of an update available for HA. But in the HA app ‘About’ it showed 2021.2. So I then went to the App Store and searched for Home Assistant and clicked on the app and it suddenly showed that a version 2021.3 was available. Once installed (updated) it now shows as 2021.3 and the pinch to zoom option is available to select in App Config - General.

I am thankful that option exists.
So many times when cycling through tabs at the top it would register as a double tap which also zooms. This feature disables that too which makes it much more usable IMO.

YES! I’m soooo glad it’s an option.

PLEASE do not ever turn it off permanently. I will pay to keep the feature. It’s crucial for monitoring my cameras. Thank you!