IOS push notifications working but after opening companion app nothing happens

Tags: #<Tag:0x00007f325c86cf00> #<Tag:0x00007f325c86ce10>

I seem to be having something weird going on with IOS notifications from home assistant.

I’ve configured the basic example from here for alarm, and I see the push notification coming in on the phone. When I slide it down (quick view) I can see the buttons, and when I click I also see the IOS event coming in at my Home assistant.

All is fine you’d say right? Well, not really, as I would expect (and managed to get it working in a previous test run a year ago) to be able to instead of swipe down, click the notification, and see the options inside the Home assistant companion app.

That is where things re not working. If I click the notification, it opens the app, but then from the app the options are not presented, and the notification disappears. I’ve checked the app notification settings and the category seems to be synced.

I’ve also tested the simple ‘Hello World’ notification, which again works fine in the home screen, but doesn’t show up if you click on the notification and the app opens.

Finally I’ve reinstalled the app and reconfigured it, and noticed 1 strange thing, Nabu casa cloud detected gave an x. This is while the phone is on 4G, and I’m not a nabu casa subscriber so not sure if it is relevant at all.

Am I having a wrong expectation that the app should show the options just like when you swipe down the notification?

See below a combination of screenshots

The options are only visible in the notification. From my memory this always worked like this.

Hmm, that feels weird though: When you get a notification and tab it (standard behavior for most apps) you lose the ability to pick an option for an actionable notification?

Maybe its my imagination that I’ve seen this work differently… but it’s definitely something I’d expect to work like that :thinking:

Don’t know how it is for iOS, but for Android you can make the notification sticky so that it doesn’t disappear when you tap on it.

Could be that iw worked differently at one point, but is a bit hard for me to imagine, becasue the current behaviour would then be a step back from the old behavious.