IOS Shortcut not working


I don’t know if this is the right category as it is iOS but not the app. I use the shortcut on my home screen for Home Assistant but it doesn’t seem to load. In safari it does load but if I use the shortcut it gives me the loading wheel and say’s “Loading data”.

The problems occur when I use it with or without NGINX proxy. It works fine from other devices.

Thanks in advance for the help!

Yes . I have the same problem. This happens since the upgrade of iOS to 10.3.

You mean the option “Add to Home Screen” to save a page in Safari to have quick access to it from the homescreen?

I just saw that Apple has an update today. Maybe fix?

I use this on a daily basis, and I am having no problems with it.
I’m on IOS 10.3.1 but as far as I know it worked with 10.3.0 as well.
Because I don’t do port forwarding to my HA server, my phone has to be on the home network for it to work (either physically home, or VPN)

I have this issue too. Just bought my wife a new iPad and updated to 10.3 and cannot log in with the home screen shortcut. My iPhone and iPad are on 10.3 but I previously had the shortcut before upgrading. That’s about the only difference. Going to upgrade to 10.3.1 and see if it’s fixed.

10.3.1 fixed the login issue for me

iOS 10.3.1 didn’t fix the isue for me. Any other things I could try?

I will look into later this day.

seems to me a home assisatant problem, rather than an ios problem. when i used HA 0.32.4 i had no problem with the pseudo app added to my homescreen, with 0.42.3 it crashes first after entering a password and after a few more tries, it get’s stuck after entering the password trying to load the page. only workaround is using safari instead of the homescreen icon.

(restarting ios does not help)

I’ve been stuck with this ios homescreen app problem for few days.
Only disabling the password makes it work.
With the password, it takes me to loading data and then crashes after a while.

No issues with chrome or safari browsers on ios.

My shortcut is working again. I did a reïnstall of Home Assistant because my ubuntu was a little funky.

I’ve got the same problem. Anyone found a solution?

You can always try the iOS app just released yesterday.


Tried it and works!

Thanks it works! IOS app adds some nice functionality!