IOS you might be connecting to a server that is pretending to be duckdns

The companion app used to work fine on my Iphone but i made some changes to home assistant which needed rebooting a few times, and after a while i realised the companion app stopped working when i was not receiving my notifications from HA.

After pulling my hair out to rectify the issue i decided to re - install Duckdns to no avail, and i even tried the no-ip with the same results regarding not able to connect through the ios app, safari or chrome on the iphone, I get this message “unknown error”, below,

but i can access the HA through the browser on my mac with no issue using the domain name and https with no issues.

This is from home assistant log when i tried to log in below, but not sure what it means as i don’t use ip ban in my config, anyone have any ideas whats going on with this, and as stated it was working fine before.

Logger: homeassistant.components.http.ban
Source: components/http/
Integration: HTTP (documentation, issues)
First occurred: 1:36:04 PM (2 occurrences)
Last logged: 1:36:06 PM

Login attempt or request with invalid authentication from ( (Mozilla/5.0 (iPhone; CPU iPhone OS 14_7 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) CriOS/92.0.4515.90 Mobile/15E148 Safari/604.1)

You are still on your local network. Try turning off wifi and connecting via your mobile carrier.

No Joy but if i connect my laptop to my 4g on the iphone, it works on the mac browser but not the companion app… a little bit more info i am using unraid with HA vm, duckdns and nginx etc all running in docker on unraid, and google wifi with the ports opened accordingly.

just tried ssl checker and it comes back with this below about invalid certificate, not sure if it will help but hmmm

Looks like your certificates have expired. Check your duckdns addon logs. Also the state of this sensor (if you have it):


Thanks tom_I for getting back to me and i just checked and no sign of a sensor.cert…

Regarding the certificate thats what i keep coming back to about the certificate, but how do you renew, i thought let’s encrypt did that automatically.

I will try and sus this certificate thing out as i think that is the way forward, the only other thing i can think off is i changed to a bigger server approx 1 month ago and i was thinking its conflicting with the change ?

Duckdns log (Unraid)


I decided to go back to the duckdns HA addon and try that version again, i put my config in and started up the addon, it went through the motions in the logs then it also renewed the certificate automatically and i could still access HA on the mac.

i tried to log in on the Iphone and the same issue, thought i would restart HA as that is what is needed sometimes and all was still good on the mac so far after restart, i tried the companion app and it went through the motions and voila all connected and working so far.

my conclusion is that the Home assistant duckdns addon automatically renew the certificate, as this is built into the addon, but the unraid app does not do this as it does not have this tweak in it’s settings ? i maybe wrong but thats the only conclusion i can come to …

Ill stick with the HA Duckdns addon for now that it works, after a bit more tinkering all is back as it should be ie notifications, snapshots, videos etc, until i can figure out the Unraid Duckdns cert renew issue,…and i know why not just stick to HA Ddns addon … but i just like to tinker and plan to have all dockers containers that i can just run in Unraid for the sake of it, plus running out of things to do ish :slight_smile:

The duckdns addon includes letsencrypt. The Unraid version probably does not include this. You would have to add it separately.

1 Like