IOS14 Apple Watch app stopped working

Hi,
Since I updated my IPhone to IOS 14 and my Watch to watch os 7 the Homeassistant Apple Watch App did not work. When I try to start it, it show the HA icon, than it disappear and the watch show it’s Home Screen. I can’t get it working. In the IPhone App are actions installed. Unfortunatelly I can’t get the watch app running to show the buttons. Can somebody help?
Oh, I tried a complete reinstall of the app, but it didn’t fix the issue.

1 Like

I have the same issue. The HA watch app crashes on launch. I uninstalled and reinstalled with no success. I even completely erased my watch and re-paired it, no success. I have a Series 3 w/LTE.

1 Like

Hi, forgot to write that I have an Watch series 3 without LTE. On my wife’s watch 4 everything runs correctly.

Hello, same for me after updating ios14 and watchOS 7 on Watch series 3 the application no longer works.

Same issue here - Apple Watch series 3 42mm WatchOS 7. Has this been reported on github?

Update: Found the issue on Github

Same problem. waiting for new release.

2020.6.2 is now out, which I believe resolves this issue. Please upgrade and let me know if it’s still a problem.

Hi zacwest,

I did the update last night and now my watch is working perfectly! Thanks a lot for the good job!

Hi the new update also immediately solved my problem for the actions but for the complications it took a restart of the watch for it to work. Good job congratulations @zacwest !!!