IP Address

Hello. I am relatively new to HA. I am not a network engineer so please be gentle. I was attempting to change my IP address to static by following some instructions I found through Everything Smart Home’s YouTube channel. I mistakenly changed it to a static IP address outside of my range on my router and now I cannot access my HA. Since I no longer can access my HA with the “updated” ip, is there a way to change the ip back to auto from the interface that I can access on my VM that is running on my PC? Any help would be appreciated. I am using an Asus router.

If you are running it as a vm try deleting the network card on the vm, reboot, add a new network card and reboot again. Then you should get a new adapter with a new mac address set to DHCP.

1 Like

Thank you for the response. I honestly would not know how to do that.

How are you running it? Virtualbox? Usually you edit the hardware on the vm. Shut it down, find the hardware settings.

That is physically not possible. Do you mean that you changed it to a different network? From 192,186,1,x to 10.1.1.x?

What, specifically, did you change?
HOW did you install Home Assistant, and on what host? There are at least three different routes and a solution may depend on which method you used to install Home Assistant.
When you had Home Assistant working, did you install the Samba Share add-on?

1 Like

It is very possible. If your router is on for example and you set for example you cannot communicate with the vm.

How do you have home assistant installed? The easiest thing to do is add a second IP to your local network adapter then access home assistant and change the IP back.

I changed it from to .255/24. When I enter .255, it is telling me it isn’t valid. I did not install the Samba Share add on you are referring to.

I installed HA on a Virtual Box

In virtual box it should be quite straight forward to do what I explain above. .255 is the broadcast address, .254 is the highest address you can use in a /24 network.

1 Like

HA is installed on Virtual Box. Running on a PC. Would I add the 2nd IP to my local network adapter on my PC?

I think that’s what I said.

How did you change it?

In the setting within HA when I could access via .175

You have the solution already :slight_smile:

you are referring to deleting the network card, correct?

Yes, that is correct.