IP Camera RTSP Feed and streaking images

I’m assuming I have something configured wrong for my IP camera display. What causes this “streaking” and how do I fix?

I had a similar issue with my amcrest cams… lowering the quality of the stream from 1080p to 720 resolved it. Or using ffmpeg as the camera type also took care of it without lowering the stream quality. (Haven’t tried too many different settings since the stream component was added so there may be other solutions now. Something like the still image URL you could direct to secondary lower quality stream if your cam has two stream settings.)

Image is basically drawn line by line.
Streaking means the image stream is faster than camera can draw+stream

-too high framerate from camera
-too high image size(1080p, 720, etc)
-image processing on view side too slow(HA receive image but must convert for viewing but cannot keep up)
-poor network performance(low bandwidth, poor wifi, etc)
-slow hdd speed(if streaming from NVR, recorded video playback, the disk may be bottleneck

Anyway, multiple possible.cause but like @bartem say…lower to 720p or reducing framerate(fps) may help

If you view RTSP stream directly in vlc or other software you get same issue? If so maybe network issue.

@tmjpugh thanks for the reply! When I view the RTSP stream through the vendor (IC Realtime) app, the video is crystal clear. I also use the exact same RTSP stream on a Crestron panel, also with no issues.

I hate the idea of dropping to 720, if I don’t have too!!

My camera setup has the IP cameras directly attached to the IC Realtime box. The IC Realtime box then gives the cameras its own IP address on its own network. So, to access, I use the IP address of the IC Realtime box, with a channel # for each camera. What I am currently using:

     - platform: ffmpeg
       input: rtsp://userid:password@ipaddress:554/cam/realmonitor?channel=4&subtype=0
       name: Front Door Camera

I can use subtype=1 to get a lower-quality stream, but it sure sucks!! The cameras are Amcrest IP2M-844E.

I’ve kicked-around scrapping the IC Realtime system and Amcrest cameras, but don’t want to do that if I can get the stream to work somewhat close to what I see in the IC Realtime App and the Crestron panel.

I have 4 amcrests with a 2104e Poe nvr and i had same issue and also ended up using ffmpeg (rtsp) with the secondary stream just to get the image clear… have you enabled the stream component? I recently started using it and even though that still image isn’t super clear the stream when I click on the camera looks great . Maybe tonight I’ll try going back to full res and see what it does now

720 vs 1080 you will not see difference unless viewing on screen 40" or larger within 5’. Probably should try lower res just to test.

Is this PC or RasPI? Is it LAN or hardwire(server not cams)?

Home Assistant is running on Docker/Ubuntu on a PC. The server and IC Realtime camera box are ethernet connected. I’m viewing on my laptop, which is connected via WiFi.

I’ll lower the resolution to 720.

OK…I missed you said you getting feed from box.

Get direct RTSP direct from camera if possible. I expect box likely has issue serving multiple streams. Might not even be real time and actually save to disk then playback from some buffer.

If cam direct not possible I’m sure lower resolution or framerate will solve