IP camera rtsp


I bought new IP camera which was recomended here and im unable to run it.

With ONVIF device manager it shows adress: rtsp://192.168.X.XXX:554/11 but it doesnt work in HA.
With browser it works under: http://192.168.X.XXX/web/admin.html

Any sugestion please?



Define “doesn’t work”? How are you setting it up in HA? What happens? What does the log look like?

When I was setting up my IP cameras, I used VLC to test that the stream was working properly. It might be worth also installing that and trying to load the stream there to confirm if the problem is with the stream or HA or how you’re configuring it.


You might have forgotten including username and password required for RTSP. Could be a root cause.


As mentioned… login/password required:

- platform: ffmpeg
  name: 406_drive
  input: rtsp://admin:[email protected]/11

also, I think you can drop the port (554 is default for rtsp)


Hello, Thank you now it works, but it is not a stream.Now it shows a picture every 10second.Is there an option where i can set it as a stream?

For some reason it’s set to update every 10 seconds in the back end.

If you click the picture a box should pop up with the image streaming.

It does that by design. To see a full, live image, just click on the picture. Make sure you set it up as follows:

  - type: picture-entity
    name: Driveway
    entity: camera.406_drive
    camera_image: camera.406_drive
    show_name: false
    show_state: false
      action: more-info

(this is a lovelace card that shows the image clean without a name or status where if you touch or click on it, it will enlarge and go live)


@Dixey great thanks, your config directed me to the point :grinning::+1::+1:

Now I use this configuration and work fine stream in home assistant lovelace card

# Stream

  - platform: generic
    name: camera1
    still_image_url: http://192.168.x.x/cgi-bin/tmpfs/snap.jpg?usr=admin&pwd=xxx
    stream_source: rtsp://192.168.x.x:554/11
    verify_ssl: false
    username: admin
    password: xxx
    authentication: basic

My card lovelace:

title: Title1
camera_view: live
type: picture-glance
camera_image: camera.camera1
  - switch.light1
  - climate.temperatura1
  - binary_sensor.motion_sensor_1
1 Like

Are you getting Lovelace to display your camera without clicking on them with your configuration? I’m using:

entity: camera.front_yard
type: picture-entity

My lovelace card looks like

If I click on them I get the camera feed which is great but I’d rather just see them without having to click on them. I tried your config but I get an invalid config error.

My Config looks like this:


  - platform: generic
    still_image_url: "http://192.168.37.x/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=wuuPhkmUCeI9WG7C&user=admin&password=xxxxxx"
    stream_source: "rtsp://admin:[email protected]:554/h264Preview_01_main"
    name: Front Yard 

I was struggling with the same thing.
I found this, Stream - Home Assistant , at the bottom they speak about streaming in Lovelace. All you still need to do is add the below lines to your lovelace.

camera_image: camera.front_yard
camera_view: live

Mine is working like this.

Thank you! That worked!

With type picture-glance you need to use camera_view and camera_image properties and work fine.

In type picture-entity i dont use it, try it.

Thanks for responding. Scorp_za helped me get it working.

1 Like

this works for me with INSTAR IN-9008FullHD

Has anyone successfully configured the motion sensor of this camera in HomeAssistant?

Hi, how did you find the still image url?

1 Like

Did you ever figure this out? Going through the same thing with a different camera right now. Have the rtsp address for live stream but can’t figure out the http address for still images?

Thanks! Works like a charm.


I have my Ubiquiti G4 PRO cameras integrated. Works fine.
Do you have suggestions on how to retrieve the motion detection from the camera?