iPhone Home Assistant Companion App can not find server, but browser and iPad Home Assistant can

Hi All,

I can access my Home Assistant server from a Safari browser window on my iPhone but not through the Home Assistant Companion App. Even though the support documentation talks about how to handle connection problems I have so far not found this exact case described. I have tried:

  1. Automatic Detection
  2. homeassistant.local:8123

On an iPad all 3 methods of connecting to the server work successfully.

The error I receive states: Failed to Connect. A server with the specified hostname could not be found. Error Code: NSURLErrorDomain -1003

I have allowed Home Assistant to access “Local Network” in settings.

I do not have multiple subnets but all devices connect through the same. Using Google Nest Wifi as router and wireless access point.

Appreciate any help or pointers you may give me.

Thanks in advance,

Try toggling the Local Network setting off then on again. There is a bug I have seen where it shows “on” but it isn’t really. Restarting the phone may also be useful here.

From the app’s perspective that error message is indicating it has no connectivity to the host. If they’re on the exact same Wi-Fi then I am not sure what’s happening. This error isn’t something the app controls.

Tried toggling “Local Network” access on/off with no improvement. Tried restarting the phone and ultimately tried deleting and reinstalling the app and restarting the phone. No improvement.

Sometimes I get error 1003, sometimes 1004.

In fact Settings now has NO “Local Network” setting at all for Home Assistant!?

There is connectivity to the host as a phone browser window can access it:

Also tried alternative addresses including https://my.home-assistant.io… which generated a different error and screen:

Feels to me that the issue is related to how the Home Assistant Companion App accesses my local network but have not explanation to why the setting is no longer available…

Now got error 1009 and suggestion that Local Network access may have been denied:

But still no ability to change it in settings:

Local Network access is, unfortunately, not at all something the app can force to happen. The system should prompt for it at the start of the app’s onboarding, when it does the scanning for local networks. It should also prompt when accessing a local IP address like 192.168.xx.yy. Worth noting that my.home-assistant.io will never work for a server address, it’s just a URL to open things.

Last ditch effort here is to reset the phone’s privacy settings. This means you’ll be re-prompted in all your apps to grant privacy settings, but it maybe will resolve this one.

  1. Go to the system Settings app
  2. Navigate to General > Transfer or Reset iPhone
  3. Choose “Reset”
  4. It’ll pop up a choice of what to reset: pick “Location & Privacy”.

Did you ever get it to work? This bug has been a PIA for me! What model phone are you using? I have this issue with the wife’s iPhone 13. Trying to figure out if it is an iOS issue or HA. Neither party seems to know how to fix it. Thanks!

Make sure that in the App access settings “Local Network” is set to on. I had EXACTLY this issue with my wife’s phone yesterday (so you can understand I put a lot of effort into solving it!)


Thanks! I was finally able to solve it… Not sure how long it will stay in place though as it comes and goes. I can’t exactly remember the steps I took to fix it cause I went nuclear on the thing. I turned off every stupid secure feature I could find on her phone… And then, just to make sure the iPhone had the exact configuration as what was on my Android, I momentarily had her on the same wifi as the android. It authenticated and gave access to the HA server. Once I had it logged in, I put the iPhone back on the guest wifi.

So I am thinking the guest wifi configuration (hard coded) on the Amplifi HD is blocking the routing of the duckdns.org URL from going out to the cloud for the HA setup process. I don’t know for sure.

And for those wondering why I have the iPhone on the guest network, it’s because she is an avid user of the facebook products. I don’t want any of the facebook apps to have access to the main network.

I hope this can help someone - cause this bug has been around for years and there are hardly any answers to the problem.

Happened for me exact the same. restart uninstall install problem solved. that is in fact how open source world is. let alone whole linux ecosystem based on such silly rules. paid ones also do the same. i am happy as it is.

Apart from the local network switch, also activate the mobile data switch when connecting via internet in the Home assistant app in Settings.

Sound logical. I tried it, but did not work. I also figured out, that accessing it via Safari results in the same problem. For some reason does not like my IPAD the HA Appliance :(.

I transferred everything from my old iPhone to a new one. After that, the HA App was running for some days. Suddenly it did not work anymore, I get error code: NSURLErrorDomain -1009. “Local Network” privacy permission may have been denied.

“Local Network” in the settings was still on, I turned it off, tried the app and did not work. Turned it on, and it could find itself the server. But still 1009.

The weired thing is, I can connect via the browser at the iPhone. And when I log out from my home network and connect via Tailscale, I can use the app.

Any ideas?

Your new iPhone is denying the HA App from accessing your local LAN but allowing the iPhone’s browser to access it. The “Location” and “Local Network” switches for this are iPhone Settings in the Apps section for Home Assistant. “Location” cannot be Never. “Local Network” must be set ON (green). That should be it. There is an outside chance these settings in coordination with the HA App present on your new iPhone are not present or are partial settings on your old iPhone, in which case the new iPhone’s OS might be defaulting to a less dangerous access mode for your new iPhone if your old iPhone is still an active Apple device registered to your Apple ID. This would be occurring as part of Apple coordinating your active Apple devices. Just a guess.