iPhone Push: Unable to find notify service for webhook ID


I recently stopped getting notifications on my iPhone. If I trigger a push message, which worked fine until recently, I get the message in HA: Unable to find notify service for webhook ID.

The HA app on the affected iPhone itself also works without problems. I can also see the parameters of the iPhone like battery level, location etc. correctly in HA.

However, another iPhone continues to work without any problems.

The only noticeable thing is that both iPhones are now only called “iPhone” and the full device name is no longer displayed.

In the meantime I have updated HA to the latest version and both iPhones to iOS 11.

Does anyone have any idea where the problem may lie?

Thank you

Perfect! Thank you…

I’m having the same issue; alerts not working and my device has been renamed to “iPhone”.

I tried doing the reset in the iOS app via Settings > Notifications > reset, but that hasn’t done the trick.

Anyone else seeing this issue?

this is issue related to ios16 afaik. service for my wife’s mobile has been renamed while mine not. After that she doesn’t get notifications from prepared automations while I do.

there is a thread discerning the issue. The ios developer is on it

Ok find solution:
in app settings (click on most top icon with your name) you find a field called “Device name”. Fill it with something like ‘yourname’.
Then find notification settings page and press RESET.
After that the notification service will be named: notify.mobile_app_yourname

Thanks for the reply. My new phone ended up arriving the day after I posted this, so instead of troubleshooting an old device, I just focused on updating my automations to notify my new device.

But this makes sense, it was right after I updated to iOS 16 that I noticed these issues. Thanks for the info.

For me it is not possible to reset.