IPhone SE2 does not connect to HA

As the proud owner of a mini PC with HA, I have been running into some issues. One problem is I consistently get the following error message, or a variant:: alamo.fire.AFError 13 and that the server cannot be reached.
The funny thing is that both my Ipad Mini as well as my work IPhone can connect with out a problem.
So where should I goe look for the cause of the error?

Can you screenshot the settings in the System Settings app > Home Assistant?

Probably, my post count is too low and I cannot add images to my posts, otherwise I would have added the screenshot of the original error message.
But if you want to see if I gave home assistant access to my home network’s other devices? Yes I did, it was the first thing I checked and remedied.
My HUE Essentials app was able to connect to the HA Bridge, but when I tried connecting this app called “inspector” to the HA Bridge it also came up with an error message.

Regards,
Dirk

Here is the actual error message

I’m getting the same error running HA on a Synology NAS and trying to connect to the app on iOS 15.1. Accessing HA via browser works fine.

That error message looks like a DNS issue. Does the internal url you have set for your Home Assistant work in the browser, or are you connecting using another means? If you use “enter address manually” instead of the discovered server, is that able to connect to the server?

1 Like

Exactly, I’ve done that yesterday and it works.

Hej Zac,
Since I have three Apple devices, I used the same method on all three and it only fails on my Iphone SEII. the app finds the IP Address, I give my userID and password, enter my 2 step authentification and crash…

But since I am so old that I remember my windows lessons, I did the following just now: deleted the app completely, reinstalled and logged on. Voila:)
No idea what gremlin caused the problem