iPhone suddenly unable to access Home assistant


#1

So, out of the blue, the app and Iphone quit communicating with HA. I’ve tried using a browser to reach HA and this also does not work?!? I’m confident that all of my testing is done at home on the same wireless network as the pi running HA.

To be clear, in the app, I’m using the URL https://hassio.local:8123

I can successfully connect to HA with my laptop and everything seems fine with HA.

The error on the app is: HomeAssistant.AuthenticationController.AuthenticationController.Error error 1


#2

Can you give some informations about your system? HA version, iOS app version?


#3

apologies.

HA 0.88.2 and iOS app 1.5.0


#4

Do you use a self-signed SSL certificate for https://hassio.local?


#5

No- I have never made a certificate, but it seemed to always work.

This AM, the app “detected an instance of HA” and asked if I wanted to connect- which worked. I noticed that it resolved the IP address and populated that field in the app. Seems to work again.


#6

I don’t know hass.io, so it may setup SSL for you, but did you actually use https or http on your browser?


#7

There is a bug which stops older iOs devices from logging in on 0.88.x

I suggest trying 0.89.1 or 0.87.1 and try logging in again


#8

Ahh this may be it. iPhone 6S