iRobot Braava

Has anyone got Braava to work in HA? The roomba works good, but unfortunitly they didnt add wifi to these Braava’s. They do talk bluetooth, just curious if I could integrate in HA somehow…

I just got one too, but I assume there is nothing we can do because of the lack of WiFi.

Yea wishful thinking lol. I seen a lot of threads in the past about making old roombas use WiFi so thought it was worth a shot:slight_smile:

I think its time to revive this old thread
There is now a new Braava

I wonder if the irobot roomba component will work with this, anyone knows?

At least it doesn’t work for me.

Tried to add my Braava m6 and was able to fetch user/pass but after adding the code and a restart, HA completely broke (even not able to open the ui at all).
I needed to change the ip of my braava to be able to restart HA (working). Really strange…

1 Like

I was just about to buy a Braava assuming it would work like my 980. Too bad.

1 Like

Hi everybody,

I succeeded to integrate my Braava jet m6 in home assistant !

  • Installation of dependances:
apt-get install python-pillow
apt-get install python-setuptools
apt-get install python-six
apt-get install python-paho-mqtt
apt-get install python-numpy
  • Recover of the folder:
git clone
  • Ultimate modifications
cd Roomba980-Python/roomba/
nano -c (replace: ssl.PROTOCOL_TLS by: ssl.PROTOCOL_TLSv1_2)
./ -R 192.168.1.x
  • Copy the username and the password

  • Modifiy your configuration.yaml:

  - platform: roomba
    host: 192.168.1.x
    username: your_username_you_copied
    password: your_password_you_copied
    name: as_you_wish
  • Restart your instance.

(Realised in a Debian 10)

1 Like

What sort of functionality do you get?

I get the same information than a roomba (except for the bin).
I regret you can’t select the room to clean.

I have both a Roomba 980 and a Braava M6. I can get the Roomba to work but not the Braava. Im kinda of new to Home Assistant and just trying to add all my devices right now. I’m running Hassio if they helps. Please how can I get the Hassio to see it correctly.


I have a 980 i7 and m6, I finally just got the m6 into home assistant last night. you have to make a change to the file to use tls1.2. I found it in these forums

Im kinda of dumb when its comes to this docker/hassio stuff. Im a windows guy. Do you have any step by step directions on how I can accomplish that.


I dont know how in Windows. If you go up about 3 - 4 posts…those are the instructions I followed.

Also, I had a lot ofg trouble hitting the right buttons when the script tells you too. I found out you can just hold the “dock” button for a couple seconds instead and that worked right away.

But you need to make that ssl change first…

i ran those commands and hassio doesn’t recognize them.

apt-get install python-pillow
/bin/ash: apt-get: not found

what does this mean

Apt-get is specific to Unix/Linux operating systems. If you’re on windows, Mac or rasp pi it would be ‘pip install’ instead of ‘apt-get install’… Assuming you already have python installed on your machine and in your $PATH.

I just used the built in Roomba integration worked fine.

pip install doesnt work either

Yes it works for the roomba but I have both a roomba and a braava. the braava doesnt work in home assistant

I’ll have to disagree:


This is the M6 with the native Roomba integration.

You probably don’t have python in your $PATH. If that’s the case it would be ‘python -m pip install’