iRobot Roomba integration needs to be reloaded

I have a iRobot Roomba 692 properly integrated into home-assistant. However, Every now and then I need to reload the integration in order to operate the robot from home-assistant or to even read its state.
What can I do to figure out what is causing the issue? Is there a way to reload the integration through an automation?
Could it be an issue that I have also the app installed on the iPhone?

Many thanks.

Just an up, anybody facing this issue? It’s like the robot is loosing the connection as the green ring turns off by itself unless I click reload on the integration.

hi!! ey, i have same roomba than you. how you get it working with ha??? I tried but at last step integration fails to add it

Thanks friend, I followed all steeps but I don’t know why I get Unknown error occurred

I have home assistant on docker, same that the problem is on password, any idea?

Sorry, can’t really help any further :frowning:

Roomba supports only one connectoin at a time, try to set continuous to false, and set delay 30.

Thanks, I will give it a try with delay to 30.

Unfortunately I get entity not available in lovelace…

Does it mean that it conflicts with the iRobot app?

Yes, if your iRobot mobile app connected to Roomba, HA can’t connect to your robot.
Try to close iRobot mobile app, then disable iRobot entity\integration in HA. So your robot shouldn’t have any connection to it. Wait for a few minutes, led on the robot must switch off, it means nothing is connected. Then enable iRobot entity\integration in HA, don’t open your mobile app in this time. And check the integration status in HA. Also before all of this, update your configuration, add these lines

    homeassistant.components.roomba: debug

Then in case of a problem put your log here.

I tried what you recommended, but I see nothing in the logs concerning roomba. Also, the led is constantly off on the roomba.