iRobot Roomba - not possible to get the blid and password

Hi all,

After updating the latest HASS version which supports the iRobot I’m facing problems when trying to install the script that gives you the BLID and PASSWORD of your roomba: GitHub - NickWaterton/Roomba980-Python: Python program and library to control iRobot Roomba 980 Vacuum Cleaner
I’ve exectued the comand “python” and I got the following message:

Traceback (most recent call last):
File “”, line 25, in
from roomba.password import Password
File “/home/Roomba980-Python/roomba/”, line 25, in
from roomba.password import Password
ImportError: No module named password

Checking the folder where is located the file I’ve verified that it exist the and exists the class Password.

Anyone knows what could be happening?

Thanks for your support!

I had similar errors on macOS, but running this worked better for me:

python3.5 ./

I still got a few errors like:

ImportError: No module named 'six'

Which was fixed by running:

pip3.5 install six
pi@homeassistant:~/Roomba980-Python/roomba $ sudo ./
Traceback (most recent call last):
  File "./", line 12, in <module>
    from roomba import Password
  File "/home/pi/Roomba980-Python/roomba/", line 25, in <module>
    from roomba.password import Password
ImportError: No module named password

Getting the same thing… six is installed but I am running python3.4. Has this component been checked on an Rpi3?

@m14t Thanks for the answer! I could not check it but I’m using a Raspberry Pi 2 with hassbian
@001010 Are you using hassbian as well?
Hope someone else has face this problem and fix it and can help us.
Thanks a lot

I gave up and followed the instructions here to get the blid and password instead:

Note you may need to install the latest versions of npm and node (I did).


RaspberryPi All-in-One installation.

What do npm and node mean? Thanks

node.js (“an open-source, cross-platform JavaScript run-time environment for executing JavaScript code server-side”)
npm - the javascript package manager

Dorita980 (the Unofficial iRobot Roomba 980 node.js library) was developed for node.js (not python) so you need to have node.js installed.

Instructions for installing as Raspberry Pi 2 are here (for example):

npm should be installed when you install node. If not:

sudo apt install npm

It works! Thanks so much!

I still fail at this miserably. So incredibly hard to get the blid and password.

sudo apt install node
sudo apt install npm
cd /home/dorita
npm install dorita980 --save
cd /home/dorita/node_modules/dorita980
npm run getpassword

Get the following errors…

npm ERR! Error: ENOENT, open ‘/home/dorita/node_modules/dorita980/node_modules/g etpassword/package.json’
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR!

npm ERR! System Linux 4.9.35-v7+
npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” “run” “getpassword” “192.168.1 .101”
npm ERR! cwd /home/dorita/node_modules/dorita980
npm ERR! node -v v0.10.29
npm ERR! npm -v 1.4.21
npm ERR! path /home/dorita/node_modules/dorita980/node_modules/getpassword/packa ge.json
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/dorita/node_modules/dorita980/npm-debug.log
npm ERR! not ok code 0

Can anyone walk me through the process of obtaining a BLID/Password. The two guides referenced on the components page are not very n00b friendly.


I’ve given up on using this method to control my roomba, unfortunately. Though I’ve had decent success with iRobot’s IFTTT integration.

Agree, it’s quite challenging. I had the same problem last week when setting-up and Roomba 960 for the first time, but was successful in the end.

I solved it by installing node.js, npm and dorita980 on my Mac using the following commands:

For Linux instead of “brew install” use “sudo apt-get update”, “sudo apt-get install nodejs” & “sudo apt-get install npm”.

I noticed that dorita980 gives the following instruction, which is not shown (to me) in the regular roomba package.
"Make sure your robot is on the Home Base and powered on (green lights on). Then press and hold the HOME button on your robot until it plays a series of tones (about 2 seconds). Release the button and your robot will flash WIFI light.
Then press any key here… "

After performing this trick a couple of times to get the timing right it provided the blid and password.

Also, it is important that you have a static IP address assigned to your roomba on your router.

If you’re getting the NOENT error using the Node tool from dorita980 on Hassbian you’ll need to update node to a new version as described on


  1. sudo apt-get nodejs npm
  2. sudo wget -O - | sudo bash;

Also make sure you don’t have another connection to the Roomba or else you’ll get ‘Connection Refused’ error (111).

Install the “SSH & Web Terminal” addon and use
docker exec -it “homeassistant” roomba-password ROOMBA-IP
will return BLID & PWD, no need to install something

@sylviepipi I used your suggestion and got the following error. Any ideas?
Error: No Such Container: “homeassistant”

remove the quotes arround homeassistant or use the the correct one, additionally please mind roomba-password has no capitals

docker exec -it homeassistant roomba-password ROOMBA-IP

Thanks fir posting this. I’m running home assistant on a raspberry pi 4 and downloaded the home assistant image flashed to micro sD card to install.

When I run the docker command, I get this message:

bash: docker: command not found.

Can someone help me with this? I really don’t know what I’m doing.

Did you install (and use) the “SSH & Web Terminal” addon ?

looks like next ha version the password is collected automaticly.