Is anyone else getting yr sensor errors saying the API returned 203 status?

Every 15 to 20 minutes since sometime last night I keep getting this in my log from the yr sensor:

2020-06-17 12:45:22 ERROR (MainThread) [homeassistant.components.yr.sensor] Retrying in 20 minutes: returned 203

I’ve got the same.
Don’t know why as i don’t use this integration. Only MeteoFrance

I am getting it too…
What’s weird is that going to this address gets a perfect xml response.

2020-06-17 14:29:41 ERROR (MainThread) [homeassistant.components.yr.sensor] Retrying in 19 minutes: returned 203

2020-06-17 14:35:34 ERROR (MainThread) [metno] returned 203

2020-06-17 14:35:34 ERROR (MainThread) [] Retrying in 16 minutes

203 means a proxy modified something, so the data may or may not be the same by the time you get it as it was from the origin server.

I have the same error also but this came after I updated this night from 0.108.3 to 0.111.3.

Logger: homeassistant.components.yr.sensor
Source: components/yr/
Integration: yr (documentation, issues)
First occurred: 23:27:22 (1 occurrences)
Last logged: 23:27:22
Retrying in 17 minutes: returned 203

I was on 0.111.0 for a few days before this started happening and I haven’t changed anything. I think it’s unrelated to the version. The response code 203 indicates a proxy modified the response, but no idea what proxy or where along the route it lives. Presumably, since it’s not isolated, it’s not our local network or ISP.

Yes, me too. Several parts of my HA setup are failing at the moment - it cant be coincidence that some upgrades have been made recently? All my issues are communications with the cloud. Lists a workaround and that it is fixed in a later version.

Workaround worked for me for a local hass install:

sed -i 's/!= 200/not in (200, 203)/' /srv/homeassistant/lib/python3.7/site-packages/metno/
1 Like

Having same issues here. I’m running home assistant supervised on Proxmox VM. It was working earlier in the evening but I did a snapshot restore and it stopped working.

Running Home Assistant: 0.110.5 is not loading and none of the yr sensors are loading.

2020-06-17 22:54:05 ERROR (MainThread) [metno] returned 203
2020-06-17 22:54:05 ERROR (MainThread) [] Retrying in 20 minutes
2020-06-17 22:54:05 ERROR (MainThread) [homeassistant.components.yr.sensor] Retrying in 19 minutes: returned 203

I thought it was my snapshot restore that broke it…

It looks like that fix is available now in 0.111.4. I’m installing that version to see if the problem is resolved.

Version 0.111.4 does seem to fix the issue for me. :+1:


Thanks for raising this and putting it into the forum.

I was having the same problem and pulling my hair out to try to figure out what I did wrong to cause it. I should have simply posted here - it would have saved me a lot of time.

Upgrading to version 0.111.4 fixed the issue.

Thank you!

For anyone with an older version of HA, the location to make the change is:

(where x is your python version)

find and change " != 200" to " not in (200, 203)"


Where can I find this path on the Supervised version on Ubuntu?