Is Duck DNS having problems?

Hello all,

Since about 24 hours ago I (and Google Assistant) cannot access my Home Assistant installation via the Duck DNS domain.
I’ve done the following to troubleshoot the issue:

  • restarted router, modem and Raspberry Pi
  • rechecked the port forwarding
  • rechecked the DMZ settings on the modem
  • tried to access HA via the local name - works
  • tried to access HA via the external IP - works
  • deleted and recreated the Duck DNS domain
  • added a secondary domain on Duck DNS - works :open_mouth:

Now I am scratching my head trying to figure out what the heck is happening. But I am 99% sure that there is something working with the DNS service. I haven’t changed anything on HA in the last days and Duck DNS was untouched since about 3 months ago.
Is anybody else having a similar problem?


On the duckDNS web admin page, does it report the correct public IP for your router?

Sorry for forgetting to mention…
Yes, the reported IP is correct and it seems to be propagated to all majod DNS backbones.

No problems here.

Are your security certificates valid?

Is your system clock time correct?

It looks like I have a problem with the certificate renewal…

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] done.
[services.d] starting services
[services.d] done.
# INFO: Using main config file /data/workdir/config
+ Account already registered!
[13:10:17] INFO: OK
[13:10:17] INFO: Renew certificate for domains: and aliases: 
# INFO: Using main config file /data/workdir/config
 + Checking domain name(s) of existing cert... unchanged.
 + Checking expire date of existing cert...
 + Valid till Jul  2 20:21:36 2021 GMT Certificate will expire
(Less than 30 days). Renewing!
 + Signing domains...
 + Generating private key...
 + Generating signing request...
 + Requesting new certificate order from CA...
 + Received 1 authorizations URLs from the CA
 + Handling authorization for
 + 1 pending challenge(s)
 + Deploying challenge tokens...
KO + Responding to challenge for authorization...
 + Cleaning challenge tokens...
KO + Challenge validation has failed :(
ERROR: Challenge is invalid! (returned: invalid) (result: {
  "type": "dns-01",
  "status": "invalid",
  "error": {
    "type": "urn:ietf:params:acme:error:unauthorized",
    "detail": "Incorrect TXT record \"\" found at",
    "status": 403
  "url": "",
  "token": "ibo9wEAExxxxxxxxxBmQkDqaxxxxxxvGvsJDq7Ujt8",
  "validated": "2021-07-04T11:10:32Z"
[13:15:37] INFO: OK
[13:20:37] INFO: OK

I can’t figure out what the problem is…

In the end I reinstalled the add-on and it works now.
I’ll have to set up a reminder 3 months from now, not to be taken by surprise.

1 Like

Exactly the same problem every 3 months :frowning:

Renewal never works and sadly this time, reinstalling the add-on hasn’t helped

Same at me, three days and counting, I donate every month to duckdns, but no support !
Now started to switch back to NOIP

Bump on this
Anyone else having problems with DuckDNS today?
Mine works intermittently.
External IP and internal from LAN (or VPN) works fine.
I had the same experience on Tuesday this week.

If you donate every month, why not buying your own domain ??

f.e. will cost you €7.99/yr at TransIP and works fine with Let’sEncrypt

got an entry in the log now for the first time - unfortunately it doesn’t say me much more than it’s DuckDNS related…:

Logger: frontend.js.latest.202308021
Source: components/system_log/
First occurred: 12:28:52 (1 occurrences)
Last logged: 12:28:52 Uncaught Error: Suspend promise not set

(xxxxxx=domain name, YYYY=port number)

a few reports on updownradar and downdetector today