Is haos_generic-x86-64-6.2.img.xz broken? It fails to boot on 4 different Intel systems

I’m trying to install HAOS (haos_generic-x86-64-6.2.img.xz) on a Fitlet2 (An Atom E3930 with the latest BIOS: FLT2.0.46.02.01).
I’ve followed the steps to create an install USB thumb drive.
Disabled boot security and selected UEFI boot off the USB.

The USB install media does not boot successfully. I get a white screen that just says “Autoboot-” with a black bar a few lines down.

I can install Ubuntu on the fitlet2, but for some reason HAOS is not working.

Is anyone else running HAOS on a Fitlet2? If so, what did you do to install it?
Does anyone have suggestions of how to get this working?

If you can install debian you could go for a supervised install and end up with pretty well the same experience.

I’m seeing the same issue with the Seeed Odyssey.

I’ve tried burning the install USB thumb drive on both macOS and Ubuntu–same issue

Some other clues… Some text shows up before the white screen:
barebox 2021.05.0 #1
Board: bare box EFI payload
.
.
.
description: UEFU OS
path: HD(Part1, Sig5209…
environment load /efivars/barebox-env-5b91…: No such file or directory
Maybe you have to create the partition.
running /env/bin/init…

Does anyone have any ideas what I might be doing wrong?

OK either I’m doing something very wrong, or there is an issue with the install image.
I’m using: haos_generic-x86-64-6.2.img.xz

I tried booting with a Lenovo ThinkCentre M90n (i3-8145U) and I get the same thing–A white screen that just says “Autoboot-” with a black bar a few lines down.

I found that if I press the up and doesn’t arrows I can get to “Boot System 0” or “Boot System 1” but if I select these some text flashes on the screen quickly then it goes back to white.

The text says:
Booting entry ‘system1’
mount: No such file or directory
could not open /mnt/system/bzImage: No such file or directory
Booting entry ‘system1’ failed
Nothing bootable found

Is this a know issue? If so, does anyone know of a fix?

With my m72e I had to flash a new bios firmware to get it to boot anything but windows. But if you are able to install ubuntu or debian then that is possibly not the problem.

Has anyone successfully booted and installed from haos_generic-x86-64-6.2.img.xz ?

I’ve also tried haos_generic-x86-64-6.2.img.xz on an HP ProLiant EC200a. It does not work on this machine either.

Seriously, has anyone successfully booted intel hardware using haos_generic-x86-64-6.2.img.xz ??

If so, what hardware did you use?

The image will not boot from a thumb drive. Flash to the Hard Drive / SSD

The fix, for anyone following along, is that the haos_generic-x86-64-6.2.img.xz should be written to your target boot media for the x86 system.

The documentation is very confusing as it refers to writing the HAOS image to the “Installation media” when in fact the disk image is not for an installer, and it should be written to the target “boot media”.

I’ve filed a GitHub issue about the documentation here: Installation for x86 systems incorrectly refers to "Installation media" vs target "boot media" · Issue #18933 · home-assistant/home-assistant.io · GitHub
and submitted a PR: Fix for Issure #18933: change "install media" to "boot media" and add more detailed descript… by hiv

2 Likes

same issue

@hive posted the solution, so what precisely is failing at this point?

@nickrout There is no longer an issue.
Summary: The old docs indicated that the HAOS image should be burned to “install media,” implying that you should boot from this to install HAOS, when in fact the image is a boot image and should be installed on the boot media.
Fix: I filed a bug and submitted fixes to the documentation to clarify the details of how the HAOS image should be used (see post above–I’ve marked that post as the solution).

@bradfordmcmanus See the post marked “Solution” on this thread for details. I submitted documentation fixes (these documentation changes are now live) that make it clear that the HAOS image is not an install image (e.g. it is not something you burn to a USB drive and then boot from and install from, like a linux distro) it is an HAOS boot image, and it needs to be written to your boot media directly.