Is Hue Component Broken in 59.2?

I can’t get any hue groups to load using discover. If I try to add the Hue component to my config, the config fails to validate.

    - host:
  allow_hue_groups: true

    - philips_hue

Results in:

Failed config
  General Errors: 
    - Component not found: hue
    - Setup failed for hue: Component not found.

This issue has been confirmed by @Mariusthvdb on the same platform as well. Anyone know if there’s a bug in the build causing this? Thanks

this might have a solution Hue motion sensors + remotes: custom component, and if not, at least is an interesting and very informative read.

havent tried it myself yet, but will shortly;-)


This setup is only working on 0.60 since then the Hue component was changed.

On 0.59.2 it should be

  - platform: hue
1 Like

Thank you, this solved the problem. The docs don’t make clear which version has the new config style. Cheers!

just out of curiosity, before breaking my setup… why would we need this in the first place? The discovery seems to work just fine? Or does the dedicated setup reveal more devices? I can’t find my hue motion sensor and remotes. so that would certainly be a + for me.

If you can’t find things. (although in my case I did it because it couldn’t find anything at all!)

I guess there’s a possibility it might help with the occasional missing item though!


ok, ill bakup first :wink:
give it a try wont hurt.


In my case, discovery wasn’t revealing Hue groups, just the individual bulbs. Adding

    - allow_hue_groups

Solved that issue.

what version HA are you on? 0.60?

and, does it show the sensors and remotes? the python scripts in the link i posted above wont do it in my setup unfortunately


I just moved to .60 and changed the hue component from the light section to the main config as described by Bram above. I don’t have any sensors or remotes to test, unfortunately.

There’s a custom component for the remotes. Hue platform won’t offer those sensors for the remotes itself. Anyway I got devconz and hue bridge running in the same time. Wondering if will also add my xiaomi stuff to devconz

yes, i think i have it correctly installed, but see nothing appearing in the <> section…
not sure whats still there fro before the upgrade when i was relying solely on the discovery and all went fine… i think ill retry that, without configuring anything and then start adding components.


to be precise: you still use this discovery setting:?

    - philips_hue

Ive deleted all setup information in configuration files, and only left the phue.conf in the /config and restarted Hassio. Happy to report that all is well and absolutely nothing has changed compared to the setup with the entrance
- allow_hue_groups
or variations .
Also, i can see the is_hue_group in the <> developer section, so at least on .60, that is showing also. Not sure what to do with these groups, since they are not used in the Hue-setup so are of nu use in Homeassistant?

check below please, ive added the extra groups to the card for reference. The bottom groups are the real groups in use, the top ones with Custom are also found, im not sure what they are?


also: with or without the entrance in different forms: no motion sensor or remote is found… which is really what im looking for

Well u might have forgotten/missed breaking change in configuration ?

probably, though i wouldn’t know what:

ive put both .py files in the custom_components/sensors folder, and added the sensor: - platform hue_sensor to the config file. Do i need anything else to discover the remote and sensor?

Again. Hue platform won’t discover the remotes . u must install / add the custom component . thus will connect to your hue hub and listen to inputs from the remotes. Hue component won’t offer this feature

i did. no result.

To be precise (rob s instructions are a bit confusing tbh: do we need the folder custom_components/sensor, or /sensors. Both are in the setup instructions …
Ive put both the files and there, and added the hue_sensor platform to the configuration. Anything else i should take care of?

Happy to report as follows:
apparently i responded too soon, or forgot the cache wasn’t cleared yet after deleting all hue setup info. I had a few restarts because of other setup changes, and all hue was lost…
so, rebuilt it with the above instructions (hue: etc etc) and back it came. After that i reinstalled the custom_component, and put both files in the custom_component/sensor folder (so not the /sensorS) and after a reboot i now am the proud owner of 2 new sensors:

and the templates, some cleaning up todo in the formatting, but working nicely! cool. (cloth over the sensor is because the switching behavior isnt programmed yet… kept turning off and on)

Cheers, and thanks for all help and info!

What u mean with clearing cache? I am also facing that sensors would appear but never cange. What did u do to clear this “cache” ? :slight_smile: Now i need you ! :stuck_out_tongue:

i meant that the hue configuration must have been still in the cache after i had deleted the setupinfo in the configuration files, and thus loaded, while in fact not called from the configuration file.
After several reboots and other changes, i saw it disappear. As it was supposed to because i deleted the setup.

Ill check whether they in fact update, havent done that yet, too excited to have them in the first place :wink:

hope to report back soon!

happy to report the sensors change instantaneously. Only the temp seems a bit off. At least according to 2 other meters…Whos right we’ll have to see for that.

Each change results in a last update change. So easy to check. (believed that to be the software update, but it is a state change updater, which is very nice)
with and without cover: