Is it me or is Z-Wave JS really having issues with batteries?

I’ve been seeing this happen more frequently upon new releases where the battery value either never updates or just sticks at some point when it didn’t use to:

  • Wallmotes used to report batteries but now just always say 0%
  • I have a Yale door lock that just always says 27%, for the first time I thought this was fixed because it dropped to 15% one day and the next to 0%, but I put in new batteries and it’s back to saying 27%
  • I have an Ecolink motion sensor that started reporting 0% battery yesterday so I put a brand new lithium battery in, still says 0% even though it’s been triggered a number of times - this was after the fact that when I went to change the battery it triggered so it wasn’t really dead but I replaced it anyway because it had been a while

All of these devices (and a few more) have been working fine in HA until they weren’t. I’ve tried removing and re-adding them to Z-Wave early on and it made no difference (Wallmotes) but haven’t tried it again since and am wondering if something about batteries is being updated in the Z-Wave JS system and slowly rendering all battery reporting useless unless you remove and re-add - just a guess. I’ve been hesitant to just try that again because not only is it a pain in the butt to do, but in the case of a Yale lock it’s a downright nightmare.

Is my Z-Wave JS just haunted? :ghost:

1 Like