Is it possible to change the Powerwall IP address in Tesla Powerwall Integration

Originally set up with wifi connection to Tesla Gateway - have a few automations using the battery charge level - HA works great - Tesla wifi not so much.
I’ve added an ethernet cable and Tesla is all connected but wired connection has its own IP address.

Is it possible to change the IP address used by the integration to the new IP? If I delete and start again will my current automations pick up on the newly installed integration?

Thanks

You do not need any integration for this. Change this on your router/accespoint whatever assigns the IP and make an IP-Reservation.

Thanks for the reply. I cant change the wireless IP address of the Tesla gateway - think it is installer set. I have set the wired connection to the Tesla gateway to an unused IP address in the reserved range not available to DHCP.
But the Tesla integration is still communicating on the Wi-Fi address - pretty sure I had to enter it when configuring the integration. I think question remains -how can I get the Tesla integration to start using the new IP address?

Thanks

Confirmed the Tesla gateway integration is using the Wi-Fi IP address - connected to a Wi-Fi network that HA can’t see and HA instantly reported Unavailable for all the data from the Tesla Gateway. Reconnected to the original network and the data came back.

If the ip is stored in a file somewhere I’m happy to try editing it!

Cheers

That’s not a thing unless you or someone else set up a second router in your house making another network and connected it to your main one. And then connected the battery to it. In which case maybe remove that router.

Are you referring to the wifi network that the battery itself is broadcasting? The one that shows up as TEG-XXX or something like that? If so the battery isn’t connected to that, it’s making it for you to connect to when you want to change administrative settings on the battery. You connect to it and go to https://192.168.91.1 (i.e. the gateway of that network) and login. I think your login credentials should be the same as your tesla ones, if not then its like the serial number of the device or something. Can google it, I haven’t done it in a bit.

But either way that network exists solely to administer the device. It provides no internet access. The battery is connected to your LAN for internet access. And I am pretty certain it uses DHCP so you should be able to specify what IP address you want for it via reservation. If its wifi interface has the IP address you want then force release it and assign it to the ethernet interface.

If your installer assigned the battery a static IP address in the battery config itself then that can be fixed in its admin interface. Go to that special wifi network its making and login to the battery. You can change it there. You can probably also turn off wifi while you’re at it. Or if not then at least tell it to forget the network details so it has to use ethernet.

Actually on that note:

Could you describe how you did this? I want to do this for mine but couldn’t figure out how. There was no ethernet port on the outside of the device I could see. From what I read there was one inside but the warnings about trying to use it were pretty dire. Seemed like there was no easy way besides taking more of the battery apart then I was comfortable with and you needed specially rated cable to handle being inside a high voltage electronic device.

EDIT: I should note that if your battery is like mine then it comes with a cellular backup so it always has internet access even if your LAN is down. I have noticed drops in connectivity occasionally when I believe it is using that cellular backup although I’m not sure. If yours is continuously using that that’s a problem as there is no way to get HA to talk to it while its using the cellular backup. Check if its got incorrect network creds in that case. If not you may need to get on the line with tech support.

Lots here to unpick. Will try to be clear.

I used the Tesla gateway browser interface (using the Tesla wifi interface Ip address) to set up the wired connection - static IP 192.168.1.39 and correct network gateway address and subnet. Router is set to reserve 1-99 so not assign DCHP addresses in that range. Connection works fine - can talk to the Tesla gateway from a browser. (just type in ip address and log on - can see energy flows and some system info)

The Tesla app on ios lets you select which wifi network the Tesla gateway connects to. Normally I connect to my home network - the same one HA is on. HA talks to Tesla Gateway on 192.168.1.38 - tesla browser interface gives no control over setting up the wifi address - installer? don’t know but I can’t change it.

Using the Tesla phone app I connected the gateway to a nearby wifi hotspot - open connection but no way for Gateway to use the wifi connection as it can’t log on to the hotspot even though it can connect.

192.168.1.38 no longer works to talk to the Gateway from my home network (no surprise!) - can easily test using a web browser - and HA shows unavailable.

192.168.1.39 still works fine as the wired connection is still on my network.

When I reselect my home network on the tesla phone app, the Tesla Gateway reconnects and .1.38 responds again from the browser and the data appears in HA.

So question remains - how to get Tesla integration to use the wired IP address not the original wireless address.

[Ethernet cable - you can easily find download the installation instructions for the gateway/battery. The standard RJ45 ethernet socket is behind the plastic cover held in place by one screw in the gateway. If you are not confident to install the cable don’t do it]

1 Like

Hm ok. I’m not really sure what to make of the hotspot situation you’re describing. Mine doesn’t have anything like that. It’s currently using wifi and just connected to my router.

I see what you mean about changing the wifi network being used in the app but really that’s a small subset of the admin options I have when I connect to its wifi network (TEG-XXX). Do you see a wifi network like if you bring your computer/phone near the gateway? If so I would suggest connecting to its admin interface like I described above and trying to change it there.

Yep I see it now. Serves me right for taking the word of random reddit folks and not doing my own research. Thanks!

Just an FYI, I literally just did this so I am pretty confident it works. Although it is contingent on whether you can actually get to the admin interface as your setup seems different then mine. Steps I did just now:

  1. Connect Gateway ethernet
  2. Connect to TEG-XXX wifi network on laptop. Password was on sticker in gateway
  3. Go to https://192.168.91.1
  4. Use client login option, enter username/password of tesla account
  5. Go to network settings, confirm that ethernet is connected
  6. Click wifi and tell it to forget any configured wifi networks
  7. Tell router to forget the Powerwall device it knows and its reservation
  8. Reserve previous IP address for Powerwall ethernet interface. Disconnect and reconnect ethernet to force a refresh

The TEG network is the same as connecting via the web browser - just fyi - saves you having to walk near to the powerwall to connect.

Thanks - deleting the Wi-Fi connection enabled me to set the wired connection to 1.38 - the old Wi-Fi ip.
Admin interface now shows Wi-Fi disconnected and wired ip as .1.38

HA Integration still working - all good news.

I still think it would be much easier if it was possible to change the IP address used by the integration - the problem with this kind of workaround is that in say 2 years time when something else changes the wheel has to be reinvented.

Anyway let’s hope the wired connection is more reliable than the Wi-Fi one. Will update in a few days in case anyone interested.

Thanks again.

1 Like

You can, its just not easy. When you configure an integration, all config details you enter get put into core.config_entries, a json file within the hidden .storage folder in your config folder. Most config editing tools HA users hide that folder because you aren’t supposed to edit it but you can if your careful. To do so you have to do this:

  1. Stop homeassistant (not restart, stop, ha core stop in the cli)
  2. Find the config entry you want to modify, in this case search that file for powerwall
  3. Change what you need to change
  4. Start homeassistant again (ha core start in the cli)

However just a heads up, there are no safety checks on this file. ha core check only checks your YAML config, it doesn’t even look at these json files since it assumes no human is editing them. If you messed up and put invalid JSON in there then you’ll get catastrophic failure on startup and I would guess the error messages won’t be helpful. I would suggest doing a cat core.config_entries | jq when you’re done just as a safety check, if JQ has no errors then you’ve got valid JSON.

Note that there is also no schema for this JSON, no where to look to see what fields are available and what the valid options are. If you put something incorrect HA will probably start just without that integration (and I would guess not a lot of helpful error messages). I would suggest only modifing existing fields and only if you are certain your new value is valid.

Fantastic info, many thanks.

Will have a careful poke around when the nights draw in!

Wired connection to Tesla Gateway has completely fixed the ‘Unavailable’ drop outs I was having with the Tesla wifi connection - worth a bit of hassle!

1 Like