Is not possible rename, disable or delete entitie

Hello. Can anyone advise me. I’m trying to rename / delete unnecessary / turn off or on an entity. Everything works until the home assistant restarts.
After the restart, all settings will return to the original settings.
Not sure how to fix this problem?

I have no idea what you are changing can you explain it more clearly, perhaps with a screen-shot or two?

For example. Sonos Speaker:
2 disabled entities.

  • Status light
  • Touch Control

I turn them on in the settings. Everything works until the server is restarted.

So you enable them AND click Update?

yes as you write. Now, as you can see, I turned it on and renamed the status light to light rename. After the restart, everything is back to normal.

Are you only having this trouble with the Sonos integration?

All entities. Sonos was an example. The only way to rename or delete unavailable entities is to edit customize.yaml or edit file in a folder .storage

No solution? I still have this problem.

How did you install Home Assistant?

Are you restarting Home Assistant or the host machine?

either as you said “commend out” the integration in customize/config.yaml to prevent them for starting … OR, go to /Configuration/Integrations … click on the specific integration/choose the device …Disabled it … click show Disabled … click “individual” entities (Delete) … then Re-enable the Device/integration again … If that’s what you want ( that’s how i got rid of “unused/unwanted entities” ) … might wanna Reload Device/Integration again, after re-enabled it

Hi, I tried today to delete / rename / disable / or even change the icon after the latest update. With no result. Each time the server / raspberry is restarted, the changes are reverted.

Hassio run on Debian GNU/Linux 11 (bullseye)

Today I tried to reinstall hassio without debian and without success. What could be the problem?

even after upgrading the operating system to version 8 without success. I tried to change the icon on any entity using settings, also using developer tools and nothing. After the restart, everything will return to the original settings.

The only option is manually in customize.yaml or in the entity.registry file.

Is it happening to you too? Do I only have it?

In the future, a problem has been found.

/config/.storage/core.entity_registry. Bad data at $.data.entities[153].capabilities.hvac_modes={'auto', 'heat', 'off'}(<class 'set'>

The local tuya integration (I combined two integrations from two creators) was faulty and the error message disappeared after updating and setting up.

This problem actually prevented writing to the core.entity_registry files

three times Hooray