Is there any reason not to use hass.io on Xen?

(Edited topic to reflect renaming of hass.io to “Home Assistant Supervised”)

Hi everybody, it seems that nowadays Home Assistant Supervised/hass.io is the preferred way to use Home Assistant, with much better integration into third party modules/extensions than e.g. the “naked” docker container I am running now (ist this true, or am I wrong?).

Now if I want to migrate to Home Assistant Supervised/hass.io I can of course use a raspberry pi 4, which is a very fine machine, but for various reasons I would prefer the normal PC architecture.

There are hass.io images for Nuc and various virtualization systems around. Is there any reason not to use Xen for this? I really do not want to use bare metal (Nucs). Xen is what I am comfortable with, and use for other things. Of course converting the hass.io images is trivial, but will I run into problems later on? Does anybody use hass.io on Xen in production (on Debian amd64 to be exact)?

TIA Ralph

I always use docker way to install hassio, way more flexible around all my machines, pi, nuc, whatever i want to use.
And with the OS i want to use.
If i can use docker, why not? :laughing:

Nowadays it is called “Home Assistant Supervised”. The name Hassio has been retired.

1 Like

Thanks a lot, did not know that! That is really helpful actually, I did not know that.

I probably should edit the thread title. I think that renaming is a good thing, much clearer and less possibilities for confusion.

Is there a reason to not run Home Assistant Supervised in Xen?

As to that I could not say. I have no idea about Xen.

1 Like

I have been using xen vm on a debian host machine for the ‘linux host’ based install of home assistant supervised. I used the ‘nonsupported’ (nonsupport is suspended) supervised on generic linux install. It worked very well and I actually just moved it to another machine for a second instance (separate building).

I tried to get xen to run the vm images supplied on the official install page without success. pygrub will not find a bootable kernel. I believe the issue is related to the UEFI image. I have not found how to set this in xen.

Thought I would share my experience.

I get that this is an old thread; but is case someone else stumbles upon it UEFI seems have been the hangup. I don’t know when they exposed it. I am running XCP-NG 8.1.0. I imported the OVA from Xen Orchestra and the only change I had to make was on the advanced tab. I set boot firmware to UEFI. Booted just fine from there.

Thanks @jimbromley, your instructions works great here also.
Anyone managed to successfully install Xen guest tools?

So far no, I opened an issue over here: https://github.com/home-assistant/operating-system/issues/822

QQ to this group of xcp-ng users. My HA OS instance seems to get hung-up on reboot at the UEFI process. Pointlessly it seems all I do is go into Xen Orchestra and load the console and it boots immediately without me actually doing anything. Have either of you experienced this also?

Thanks!

I doubt it will go anywhere; but I crossed posted to the Xen Tools repo; maybe they’ll expand the install.sh to support buildroot. https://github.com/xenserver/xe-guest-utilities/issues/88

ah yes, apparently the github tracker is not for features.

New thread here: Add xen guest tools package to HASS OS