Is there any way to determine status while restoring from backup

So, I’ve used Home Assistant for a while now and I have it running on Nuc with a 500GB SSD for the last couple of years. Yesterday I noticed that it became unavailable (no web service, couldn’t even ping the IP) I went to look at the screen and a lot of stuff was scrolling by. I saw nvme01p8 and Read-only file system in the messages so I figured the SSD was giving up. I tried the three-fingered salute (--) and I saw a message like Unable to execute shutdown binary! which seemed bad – the file system must have gone away or something. So, I held the power button to shut it off. When I turned it back on it fired right up and started working again (I created a full backup, just in case).

Can someone check out this screenshot and let me know if my judgement of SSD was correct?

Also, what’s the best way to troubleshoot a bad disk on Home Assistant OS? I feel completely ham-strung on debug methods with the thing – in this case, I couldn’t even get to the command prompt locally… the system was just spitting out tons of detail to the screen and didn’t seem to accept any keyboard commands other than -- which only failed to reboot.

I went out and bought a new SSD and I’m working on restoring the backup to the new one at the moment. :crossed_fingers:

It has been running for a long time (1.5hrs) and the frontend is still unavailable. How can I check if it is stuck or still running?

1 Like

I left it for two hours and it finally finished and came up successfully. The backup/snapshot was 1GB in size but I didn’t expect a two hour restore time.

It would be REALLY nice if there was some log somewhere we could monitor or cat periodically to see what the hell is happening. I tried ha core logs, ha su logs, etc. and couldn’t find anything that told me about the restore process. :expressionless:

1 Like

It’s not perfect, and it requires you to still be connected via keyboard or monitor…ish. I got lucky and one of the first add-ons to be restored was my SSH access - followed by uptimeKuma to tell me SSH was active. Anyways…

I used this command to monitor the restore after that.

watch -n 10 “ha supervisor logs | grep -v ‘logs’”

it will tell me what add-ons are currently being restored, which is as good a metric as any I have. Still not fun just waiting, but I can at least see progress

4 Likes