Is there indication that Home Assistant is being installed after "sudo systemctl start install_homeassistant.service"?


#1

Hi Community,

Have had quite the journey setting Hassbian up. One last question remains.

I followed the Home Assistant on a Pi Zero in 30 Minutes guide and got to the point where I type in

[email protected]:~ $ sudo systemctl enable install_homeassistant.service
[email protected]:~ $ sudo systemctl start install_homeassistant.service
[email protected]:~ $ 

There’s no indication that it is doing anything. It just carries down to a new line and that’s that. Is this normal? Should there be some display indicating that there’s activity, or is no news good news?

It’s been over half an hour, nothing on the ip:8123 or http://hassbian:8123 or http://hassbian.local:8123 so I am assuming I’m missing something.

Thank you all for any help.

Edit:

Based on information on another post, is this an indication that something is missing?

[email protected]:~ $ cd home/homeassistant/.homeassistant/
-bash: cd: home/homeassistant/.homeassistant/: No such file or directory

[email protected]:~ $ systemctl status [email protected][email protected] - Home Assistant for homeassistant
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled)
   Active: failed (Result: exit-code) since Fri 2019-03-15 05:43:11 UTC; 41min ago
  Process: 821 ExecStart=/srv/homeassistant/bin/hass (code=exited, status=203/EXEC)
 Main PID: 821 (code=exited, status=203/EXEC)

#2

First of all to cd into the home assistant directory the command is:

cd /home/homeassistant/.homeassistant

Next what does your /etc/sysemd/system/[email protected] file look like. It should look similar to this:

#
# Service file for systems with systemd to run Home Assistant as the homeassistant user.
#

[Unit]
Description=Home Assistant for %i
After=network.target

[Service]
Type=simple
User=%i
ExecStart=/srv/homeassistant/bin/hass
SendSIGKILL=no

[Install]
WantedBy=multi-user.target

#3

I followed the instructions from the official page here.

It worked well for me on a wired connection. All I had to do was boot and wait. I It did take about 10 minutes to install on my RPi 3B+.


#4

Hi Mate,

Thanks for the reply. I’m really at a loss here.

Here’s what I got from the first;

[email protected]:~ $ cd /home/homeassistant/.homeassistant
-bash: cd: /home/homeassistant/.homeassistant: No such file or directory

Second part;

[email protected]:~ $ sudo nano /etc/sysemd/system/[email protected]
GNU nano 2.2.6                      File: /etc/sysemd/system/[email protected]                                                   




                                                                     [ New File ]
^G Get Help              ^O WriteOut              ^R Read File             ^Y Prev Page             ^K Cut Text              ^C Cur Pos
^X Exit                  ^J Justify               ^W Where Is              ^V Next Page             ^U UnCut Text            ^T To Spell

It looks empty. How stuffed am I? Anything I can do to get everything installed?

Thank you again. I wish there was a way to say super thanks here


#5

@TraktorS2run this:

sudo hassbian-config install homeassistant --force

#6

I’ve never installed Hassbian on a RPi Zero but that is normal in my experience on a RPi3.

Has the Pi connected to your wifi?


#7

You!! @ludeeus

Wow!

You’re the legend that gave me hope over this process! I saw that command commented on another person’s post a day or so ago and managed to get some way through before packages started failing. Thank you for being so active. You seem like you have a lot of patience for people trying to learn the OS/software.

My initial problem here was my wpa_supplicant not being read by the system on first boot. Managed to get past that today and wifi on first boot, but it looks like something isn’t installed.

I’ve tried that command. Here’s what I got;

[email protected]:~ $ sudo hassbian-config install homeassistant --force
/usr/local/bin/hassbian-config: line 58: /srv/homeassistant/hassbian/suite-states: No such file or directory
Home Assistant install script for Hassbian
Copyright(c) 2017 Fredrik Lindqvist <https://github.im/Landrash>
Changing to the homeassistant user
Creating Home Assistant venv
Changing to Home Assistant venv
Installing latest version of Home Assistant
Downloading/unpacking homeassistant
  Downloading homeassistant-0.89.2-py3-none-any.whl (3.9MB): 3.9MB downloaded
Downloading/unpacking hassbian
  Could not find any downloads that satisfy the requirement hassbian
Cleaning up...
No distributions at all found for hassbian
Storing debug log for failure in /home/homeassistant/.pip/pip.log
Deactivating virtualenv
Enabling Home Assistant service
Disabling the Home Assistant install script
Starting Home Assistant

Installation done.

Your Home Assistant installation is running at 192.168.0.28:8123 or if prefered http://hassbian.local:8123

To continue have a look at https://home-assistant.io/getting-started/configuration/

If this script failed then this Raspberry Pi most likely did not have a fully functioning internet connection.
If you still have issues with this script, please contact @Landrash on gitter.im

[email protected]:~ $ 

Do you have any commands that I can try the ol cut and paste here?

Thank you so much.


#8

You mean commands for hassbian-config? I think hasbian-config --help gives a rough list

“addon features” are mentioned here in the README.

Upgrade instructions are at the bottom of the installation page.


#9

It looks like you have an older version og hassbian-config

To get the latest (and greatest)
First run this:

sudo apt install -y apt-transport-https
echo "deb [trusted=yes] https://gitlab.com/hassbian/repository/raw/master $(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/hassbian.list
sudo apt-get update
sudo apt install upgrade -y

Then this again:

sudo hassbian-config install homeassistant --force

#10

Just as an experiment, I installed the hassbian scripts in a Debian VM & installed.
Raspian & Linux install instructions might be good additions to the instructions.

Right now, I am trying to get DuckDNS working after running the script.
I had it working on a previous Hassio install but am moving to Hassbian.


#11

Thanks @ludeeus

Here’s what happened!

[email protected]:~ $ sudo apt install -y apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
apt-transport-https is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~ $ echo "deb [trusted=yes] https://gitlab.com/hassbian/repository/raw/master $(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/hassbian.list
deb [trusted=yes] https://gitlab.com/hassbian/repository/raw/master jessie main
[email protected]:~ $ echo "deb [trusted=yes] https://gitlab.com/hassbian/repository/raw/master $(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/hassbian.list
deb [trusted=yes] https://gitlab.com/hassbian/repository/raw/master jessie main
[email protected]:~ $ sudo apt-get update
Get:1 http://archive.raspberrypi.org jessie InRelease [22.9 kB]                       
Get:2 http://mirrordirector.raspbian.org jessie InRelease [15.0 kB]                        
Get:3 http://archive.raspberrypi.org jessie/main armhf Packages [170 kB]
Get:4 https://gitlab.com jessie InRelease                                                     
Ign https://gitlab.com jessie InRelease                                                                          
Get:5 https://gitlab.com jessie Release.gpg                                                                      
Ign https://gitlab.com jessie Release.gpg                                                      
Get:6 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,539 kB]
Get:7 https://gitlab.com jessie Release                        
Ign https://gitlab.com jessie Release                                              
Get:8 https://gitlab.com jessie/main armhf Packages                            
Get:9 http://archive.raspberrypi.org jessie/ui armhf Packages [58.9 kB]
Get:10 https://gitlab.com jessie/main Translation-en_GB            
Get:11 https://gitlab.com jessie/main Translation-en                                          
Get:12 https://gitlab.com jessie/main armhf Packages                                          
Get:13 https://gitlab.com jessie/main Translation-en_GB                                                                                              
Get:14 https://gitlab.com jessie/main Translation-en                                                                                                 
Get:15 https://gitlab.com jessie/main armhf Packages                                                                                                 
Get:16 https://gitlab.com jessie/main Translation-en_GB                                                                                              
Get:17 https://gitlab.com jessie/main Translation-en                                                                                                 
Get:18 https://gitlab.com jessie/main armhf Packages                                                                                                 
Get:19 https://gitlab.com jessie/main Translation-en_GB                                                                                              
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB                                                                                     
Get:20 https://gitlab.com jessie/main Translation-en                                                                                                 
Ign http://archive.raspberrypi.org jessie/main Translation-en                                                                                        
Get:21 https://gitlab.com jessie/main armhf Packages                                                                                                 
Err https://gitlab.com jessie/main armhf Packages                                                                                                    
  HttpError404
Get:22 https://gitlab.com jessie/main Translation-en_GB                                                                                              
Ign https://gitlab.com jessie/main Translation-en_GB                                                                                                 
Get:23 https://gitlab.com jessie/main Translation-en                                                                                                 
Ign https://gitlab.com jessie/main Translation-en                                                                                                    
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB                                                                                       
Ign http://archive.raspberrypi.org jessie/ui Translation-en                                                                                          
Get:24 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3 kB]                                                                    
Get:25 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [88.1 kB]                                                                   
Get:26 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]                                                                        
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB                                                                              
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,939 kB in 59s (167 kB/s)
W: Failed to fetch https://gitlab.com/hassbian/repository/raw/master/dists/jessie/main/binary-armhf/Packages  HttpError404

E: Some index files failed to download. They have been ignored, or old ones used instead.
[email protected]:~ $ sudo apt install upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package upgrade


[email protected]:~ $ sudo hassbian-config install homeassistant --force
Home Assistant install script for Hassbian
Copyright(c) 2017 Fredrik Lindqvist <https://github.im/Landrash>
Changing to the homeassistant user
Creating Home Assistant venv
Changing to Home Assistant venv
Installing latest version of Home Assistant
Downloading/unpacking homeassistant
  Downloading homeassistant-0.89.2-py3-none-any.whl (3.9MB): 3.9MB downloaded
Downloading/unpacking hassbian 
  Could not find any downloads that satisfy the requirement hassbian
Cleaning up...
No distributions at all found for hassbian
Storing debug log for failure in /home/homeassistant/.pip/pip.log
Deactivating virtualenv
Enabling Home Assistant service
Disabling the Home Assistant install script
Starting Home Assistant

Installation done.

Your Home Assistant installation is running at 

Some errors in there. The W: Failed to fetch https://gitlab.com/hassbian/repository/raw/master/dists/jessie/main/binary-armhf/Packages HttpError404

and

Could not find any downloads that satisfy the requirement hassbian seem to be a worry?

Is this happening because things are missing from my Pi and is there a list of things I can try?

Thanks for any help Mate


#12

Jessie?!??? :open_mouth:

Grab a fresh version of the Hassbian :slight_smile:


#13

Legend. Thank you. I just used the pi zero image on the site and thought that was Hassbian.

Could you give a new user a break and let me know what I need to enter into the command line to install that?

Thank you mate


#14

You got a link to that?

That will not be possible, this will require a reflash of the SD card.


#15

Okay thank you, VERY happy to reflash!

I thought I got it from the “home assistant on a raspberry pi zero w in thirty minutes” post on the site. I hope I’m wrong and that you’ve got the answer that will connect me!

I am really embarrassed to ask. I can see the github page, but how do I download something from there that I can flash to an SD card?

It feels like I’m so close! I’ve learnt a lot up to this point which is great, can’t wait to get it working.


#16

I posted the official hassbian link in post 4 here. Is that what you want?


#17

Click here:


#19

You are my hero :heart::heart::heart:

I had the wrong damn OS. Doesn’t that explain everything!


#20

Be sure to unzip the download before flashing it to your SD card.
I think some people have has troule reusing cards. I have not had thet issue but I follow the Raspberry Pi instruction for format the card with SD Formatter first.


#21

Sweet, well I’ve downloaded from that link. Looking back I definitely had hassbian installed because my ssh session said [email protected]

I’ve dropped the wpa supplicant and had wifi on first install. Able to change the ssh password and have let it sit for the 20 mins. It looks like the same situation, no Home Assistant :frowning:

I followed the instructions in the “Home Assistant on a Pi Zero W in 30 mins” and got this;

[email protected]:~ $ sudo systemctl enable install_homeassistant.service
Failed to enable unit: File install_homeassistant.service: No such file or directory
[email protected]:~ $ sudo systemctl start install_homeassistant.service
Failed to start install_homeassistant.service: Unit install_homeassistant.service not found.

I followed your instructions above and got this;

[email protected]:~ $ sudo hassbian-config install homeassistant --force
sudo: hassbian-config: command not found

Tried the sudo nano /etc/sysemd/system/[email protected] and it is empty.

Tried cd /home/homeassistant/.homeassistant and the directory does not exist.

[email protected]:~ $ cd /home/homeassistant/.homeassistant
-bash: cd: /home/homeassistant/.homeassistant: No such file or directory

I followed your instructions at 8 and they worked well until I got this error;

[email protected]:~ $ sudo apt install upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package upgrade
[email protected]:~ $ sudo hassbian-config install homeassistant --force
sudo: hassbian-config: command not found

Is there anything I can share to work out what is going on? I ran wireshark to check for traffic coming from the Pi and found almost nothing passing.

I want Home Assistant so bad and it feels like it is so close!!!

Help me @ludeeus wan kinobi, you’re my only hope. turns off R2D2 recording.