Is there really no way to use a Bluetooth dongle with HASS.IO!?

I feel as if my onboard Bluetooth has gone bad. The add-on says it’s running, but more and more frequently it was losing detection on devices until a complete restart until alas it no longer detects devices at all… I was using it in conjunction with ping for presence detection as my linksys smart router would frequently detect our iPhones as Ethernet devices so of course when you leave, you haven’t really left because well, and Ethernet device doesn’t disconnect… it’s crazy! Am I the only one that has had the issue with the Bluetooth or am I really out of luck and I will have to purchase another pi to correct the issue?!?

Have you finally found a solution to use a Bluetooth dongle with Hassio?
The on-board antenna is way too weak to detect devices placed more than 4m away in my case. I really need a decent dongle.

i did not. i ended up going back to using my pi anyway. my VM kept dropping throughout the day so i got fed up with it

My solution was buying a ESP32 bluetooh and flash this

All via hassio addon :wink:

1 Like

Try monitor and a pi zero w

Is there still problem connecting Bluetooth dongle to hassio vm ?

I just moved over to a VM yesterday a Chinese NUC. Have had zero success and been bashing my head trying to get Bluetooth to work. Gave up and flashed a ESP32. Working (almost) fine now, my miFlora’s are showing everything except battery status.

1 Like

Interesting workaround ! But how it works ? Is there a way to communicate with esp32 inside hassio easily ?

esphome addon

1 Like
OBJECTIVE install BT dongle to running on docker inside Debian LVM in Proxmox VE 
a) In Proxmox check for USB devices and take a screenshot via "lsusb"
b) Install USB dongle to machine and check additions via "lsusb"
c) In Proxmox passthrough the USB to the required VM- make sure you assign to new USB port (say if port 0 and 1 are already assigned to other USB then use next available which is 2)
d) STOP and start the target VM in Proxmox
e) Now in VM -consol check USB "lsusb". Note: It may be good to check this before installing new USB devices so you know of the changes
f) Make a note of the USB port assigned so that next time you add a USB you do not overide which make all entities goes missing for previously installed USB
g) To get USB dongle working even in as I have installed it on Debian use this command in proxmox-> HA VM->concol
sudo apt install bluetooth

From <> 

h) Now or even before add the component switchbot to config
 - platform: switchbot 
    mac: 'MAC_ADDRESS'

MAC address can be found in the switbot app-> for each device configured pressing settings icong  and then tapping … in right hand top corner. Type mac address simple letters
From <>

this doesn’t work for hassio… you can’t apt or install specific packages

It should as I am running hassio as LVM proxmox->Debian strech OS->Docker

Yeah that’s awesome and all… but the dude is running (homeassistant). probs on a Rpi 3 or 4.
Your advice doesn’t work for that. I also don’t get why you are wasting computing resources on:
proxmox (debian) – vm with debian – Docker (virtualization). Why not run your hassio image directly as VM? I have bluetooth working in hassio just by passing through the dongle.

I have bluetooth working in hassio just by passing through the dongle.

I am in a similar configuration: I am running home assistant (hassos_rpi3-5.9) on a Raspberry Pi 3B+ and would like to use an external USB Bluetooth dongle to extend the bluetooth reach.

From what I have understood, any linux-proof dongle will do the job. I will select one with an external antenna hoping it offers a longer range. Will a dongle with the latest specification (Bluetooth 5.2) be of any interest? Any recommendations?

Regarding hassos configuration, will it work straightforwardly as soon as I plug the dongle in, or do I need to adjust some specific parameters (to disable the internal Bluetooth module, to install the dongle specific drivers)?

Thanks in advance,

For the type of dongle I can’t assist you. I bought the cheapest of the cheapest thing, it did work straight out of the box after passing through. Its the same like plugging it in a raspi. I didn’t need any drivers or modules if I recal correctly. Anything that is plug and pray of Linux will do just fine

A silly question: how can you be sure that your bluetooth connections go through your dongle and not through the internal Raspberry Bluetooth module?

Because you select a serial device to use/monitor. For me it will be /dev/ttyACM0 or something. Your raspi Bluetooth will be something else.

I cannot find a setting in configuration.yaml (or in any of the other basic configuration files I have checked) pointing at the internal Bluetooth device (in order to adjust it to /dev/ttyACM0).
Where did you adjust that parameter exactly?

hello, did you find a solution?
I have the same problem, I bought a dongle but i don’t know how to set it as main bluetooth. :frowning:


Bit of a late response, and not complete. But if it helps anyone…
It’s been quite a while since I did this… You need to create a config.txt with content like this:

# Disable Bluetooth for RPI4

This will disable the onboard BT. If memory servers me right, the dongle will automatically become default.

The config.txt is in the host os side, so you need to gain access before editing it: