Is there something going on with DuckDNS?

Hi There,
I’ve tried these last two days to see what’s going on with my DuckDNS without any luck? are there any problems with the DuckDNS server itself?.
My configuration has been working for several months witthout any problem, but 2 days ago I lost access via duckdns without doing any modification to my whole setup. I can still access directly to HA outside LAN via https://myinetIP:8123 (so I don’t see any issue with my router port forwarding capabilities), but not via duckdns. I’ve checked my duckdns account and the recorded ip is still ok, also the log of duckdns add-on doesn’t show any problem either.
If anyone could point me out to the solution or giving me any thoughts would of course be much appreciated !!

DuckDNS has a history of failing to work for a while. The first check is usually to see if a tool like MXToolbox can resolve your DuckDNS hostname to your WAN IP.

It’s indeed quite frustrating. I’ve searched in the web without any luck. I tried MXToolbox and yes, DuckDNS hostname can resolve my wan ip. So no issue over there…

I read somewhere on this forum that duckdns had been suffering a denial of service attack.

It was also being discussed on Discord - and as people there found the problems were regional. Some places could resolve just fine, other places they couldn’t as their regional DNS servers were non-responsive.

There are a number of other (free) Dynamic DNS providers out there - it wouldn’t hurt to investigate some of those. I’ve certainly used and in the past and had no issues with either, but there’s plenty of others.

Yes, most probably it’s a regional issue as I’m able to access now from my laptop with an European vpn, but no possible from my mobile nor using my mobile netwrork connection …

if someone faces the same problem… there was indeed a problem with regional dns server… I moved out from duckdns to other provider (freeddns) + Letsencrypt and no issues at all