Is this the perfect standalone tablet for HA?

Some units seems to have trouble with the adb remount command.

To work around it, transfer the desired bootanimation.zip to /sdcard/Download then complete the installation commands in a terminal on the device itself.

2 Likes

@mattmon awesome!! I’ll give that a try. Thanks!

An update to the loud volume bug. It appears to be with how Fully Kiosk sets the stream type. The app is using a deprecated function and very short streams use usecase(1: low-latency-playback) which is ok but longer streams/larger files sometimes end up with usecase(4: compress-offload-playback2) which doesn’t go well and causes playback to be full volume. I’ve reported it to them and asked them to fix it, but who knows if/when that would happen.

As an interim fix, only stream 3 (media) is affected by this, so we can modify the home assistant integration to use stream 1 (system) instead. In the Fully Kiosk integration’s const.py file, change the value of AUDIOMANAGER_STREAM_MUSIC from 3 to 1 and media and TTS will stream on the system channel at the right volume. As an added bonus, the volume buttons on the device control that channel by default. The volume controls in the integration appear to continue to work as expected as well. Other than having to overwrite a built-in integration to change one value, I haven’t had any issues with this approach.

3 Likes

Ok latest method to get A11 and working the simplest on Windows (no need for edl or python) - shoutout to @dinki

  1. Follow pre-requesites here

  2. The driver may (on WIndows 10 or 11) have a yellow ! next to it. Check Driver details and it indicates this is due to the driver not being signed. On your PC goto:

Settings > Windows Update > Advanced Options > Recovery > Advanced Startup --> Restart Now

In the boot screen select:

Troubleshoot > Advanced Options >  Startup Settings > Option 7
"Disable Driver Signature Enforcement"

This allows the Qualcomm driver to be used by Windows.

  1. Now proceed as normal to flashing the device as provided here
    FWIW I am using a USB-C to USB-C connection. I have tested with USB 3.0 and USB 2.0.

NOTE if you reboot your PC the driver signature ignoring process will need to be compelted again

EDIT: also love this device. Got complete control of my home from beside my bed. Cameras visible via a swipe card, and if the baby is asleep thats on the home screen. This could just be the perfect device for HA!

3 Likes

did you figure this out? (looking to retroactively change the boot splash also)

Not yet. I might have a go tomorrow. Not sure if I have all the info needed to try this yet though.

1 Like

Hi, it may be a lazy question, but the thread is ATM 1146 post long, I hope you’ll have a bit of mercy with me :slight_smile: . At this point what doesn’t work on the thing if flashed with A11?

I’ll receive my think view tomorrow and I 'd like to know what Android version to flash.
Ty in advance.

I feel like this thread has been going in a bunch of different directions, and I’ve been struggling to follow and keep up with everything… Android 8, Android 11, Linux/postmarketOS, different features that work or don’t work, etc.

Could someone share a breakdown of the current status of the different ROM options or what the current recommended configurations are?

3 Likes

Android 8.1 is “stable” and still my recommendation.

Android 11 is “experimental”. It seems to solve audio problems for some people. Further development seems to have stalled, afaik.

PMOS is also experimental. It’s under active development and is already quite capable. It’s more powerful but also more complicated than Android.

1 Like

I’ve been running A11 on one device for a few days now with my dashboard showing. There are definitely some benefits including better working audio and a fix to an odd problem I still have with the touchscreen on 8.1 taking a few seconds to ‘wake up’ and respond after no interaction for some time. That is a fairly major annoyance for me as if you press a button, it doesn’t immediately respond and it’s likely someone (including me) will press a second or third time resulting in unwanted results.

The down sides to A11 is a very specific issue with bubble card and popups not working after a period of time (possibly after the screen has been off and is turned back on again). That’s a very specific issue that I’m still trying to troubleshoot. Also, on A11 Go - Fully Kiosk (kiosk mode) isn’t fully supported. There is a work-around from their support site but auto starting apps cause the device to crash/lockup on start. There is a work around by using Autostart Manager app to launch Fully Kiosk but the full lockdown doesn’t work. Probably not an issue for us but in a household with lots of prying fingers, that could cause support issues maybe.

Overall, I’m really liking A11 now that I finally got it working. Both 8.1 and A11 have their issues so it’s probably a bit of a tie for me, maybe A11 edging into the lead slightly.

I do plan to try out the View-Assist functionality which I think only works on A11. If that all works for me, A11 will be the clear winner.

Like with any of these ‘hacked’ devices, the people working on getting them working can only go so far and it is possible some issues will never be resolved.

Like I said in my previous post a little way up this thread, I did try PMOS for a bit (and will probably re-visit later), as it’s Linux based, it doesn’t work as well for me as there’s no Fully Kiosk and all the lovely functionality that gives will have to be done somehow else (more difficult for sure). It also has a load of display issues in my testing and other UI elements that aren’t quite right. Shows real promise if these can be fixed but has a little further to go yet. The devs are doing a fantastic job though and it seems to be the best supported and active option so far.

2 Likes

Talking about A11 - has anyone managed to fix the crash to Lenovo logo when any app is set to auto start?

1 Like

Hey thanks @pgale

I may be missing it, but is there a step by step guide to installing A11?

I have the same issue on my 8.1, where after a while the screen gets “sluggish”… Its literally the only issue but very annoying…

Id like to try A11…

1 Like

Yup, you can find manual here

3 Likes

thank you, i’ll give it a go

Guys, it seems to me that my device is bricked. I managed to run Android 11, but I decided to revert to my A8 backup, and now the device won’t turn on at all. It’s visible through EDL, but when I try to flash it again, I get an error:

Qualcomm Sahara / Firehose Client V3.62 (c) B.Kerler 2018-2023.
main - Using loader imagez/prog_emmc_firehose_8953_ddr.mbn …
main - Waiting for the device
main - Device detected :slight_smile:
sahara - Protocol version: 2, Version supported: 1
main - Mode detected: sahara
Device is in memory dump mode, dumping memory
sahara
sahara - [LIB]: Error: Invalid mode switch

Is it possible to exit from dump to stream mode? The Lenovo recovery tool also isn’t working, but I’m not sure if it’s VMware’s fault. Thanks for any help.

EDIT:
Also edl tool is waiting forever for the device when I want to reflash :frowning:

EDIT2: Force EDL cable was the answer :smiley:

EDIT3: One think I have learned from debricking ThinkSmart - when you recover device using Lenovo tool is enabling adb even for the newest firmware :slight_smile:

adb logcat - doesn’t even seem to spit out any messages when I connect my USB hub (which works with my phone), or 5 different (possibly) USB OTG cables I used.

Read around online and saw settings like
“/sys/class/power_supply/usb/usb_otg” ← was zero, I used adb root to switch it to 1, and still nothing.

Also tried these usb otg checker apps which said non compatible.

Any help would be appreciated. Any chance you can list the cable that worked for you? I’m trying to connect it to an Ender 3 v2, which has a microusb connector, so maybe usb-c hub + usb-a/microusb cable is an unhappy combination.

(if it matters, I’m on build number: Lenovo_Kingston_OS_PV_191011_V0.0.35-userdebug-PIN-TEST
kernel version: 3.18.71-ge1d404943da7-dirty)

that also happened to me even when not using the HA companion app (e.g. using the Sonos S1 app). My (not ideal) workaround is to set the sleep to “Never” (Settings → Display → Advance → Sleep → Never)

I’m using newest, unlocked, original firmware and it’s blazing fast. No screen flickering, no hang ups, everything runs smoothly.

1 Like

Thanks. I’m pretty sure I have that set already but I’ll go and double check. Fully Kiosk is set to keep the screen on permanently but something is still happening or sleeping it seems, even when the screen is on and CCTV camera feeds updating et.

Has anyone had any luck getting the proximity sensor working? I’m running the recommended ROM from OP, with Automagic installed and all permissions enabled. But no matter what I do, I always see “Current Value: 0.0 cm”