Is this the perfect standalone tablet for HA?

I think this was in relation to A11, not this ROM 8.1

Are you running 8.1?

@mattmon any special steps to get Octoprint working? I got everything flashed and installed on the device, and found a USB-C dongle that works with my printer (and my phone), but when I plug it into the ThinkSmart, Octoprint never says “printer connected”.

I’d be surprised if you find anyone that’s tried this on the View device. Not sure if I’ve heard of anyone actually using the USB port either.
What are you trying to achieve? Use it as a display for octoprint?

Yes, I am using 8.1. Had no flickering in fully kiosk though.

  1. Boot into recovery mode by holding volume up while powering on. Perform a factory reset and reboot.
  2. Once you can see the Lock Screen, Finish up user provisioning:
    adb shell settings put secure user_setup_complete 1
    adb shell settings put global device_provisioned 1

After factory reset and reboot I ended up seeing the normal homescreen instead of the lockscreen. I waited a few minutes but nothing happen so I used the adb commands

@pgale Since you also use fully kiosk, I wanted to ask what you have set so that the display turns on again (after time or movement). At the moment it only goes off for me, but unfortunately it doesn’t go back on after a certain time or on movement. It can also only be switched off and not on via the HA integration. It seems that the app cannot wake up the device.

Using it as the Octo4a (octoprint for android) full server. Only trying it because it was mentioned as working in this comment (from Mar 16)

What method are you using to turn the screen off?

What I have is:

mmWave / PIR presence sensor in every room
Five ThinkSmart View devices
I use Blacky’s ‘sensor light’ blueprint to turn the device screen on/off based on presence. I use a series of simple scripts to do this. Using the Fully Kiosk integration, I first dim the display using the FK screen brightness setting and then a second or two later, I turn it off using the display on/off switch. Then on presence detected, I turn the display brightness back up to full (255) using screen brightness which also turns the display on.

I do this as you can’t turn the device on using the screen on setting, only turn it off. There’s obviously an issue there but the way I do it gets around that.

Works perfectly and reliably.

I want my devices to always be on when the room is occupied, no manual waking it up or waving your hand frantically in front of it !

Hope that helps.


Ah ok. I’ve not tried that. But I have a Voron 2.4 and use klipper and klipperscreen on a pi4 with touchscreen as my monitor/control. It’s a few years since I used Octoprint.

Did you see my write up here?

Thank you very much :star_struck: the display brightness trick did it for me. Now I have to figure out how to use it at the moment, because I have no mmWave sensor in the room right now. I saw your thread, but did not find any hint on how you are able to turn it on again. I will check out the blueprint you mentioned and see if i can use it for my environment at the moment.

Yeah, the trick is to use the display brightness to turn the screen on.

Are you using an OTG cable?

Adb logcat should give some insight into what’s not working.

A11 progress :slight_smile:

If you’ve read any of my posts here, you’ll have seen that I struggled with getting A11 installed and it would just hang at the Lenovo logo. I tried for days with installing most of the stock images (Teams etc) and re-installing A11 over the top. It was very frustrating and I gave up several times as nothing I tried would work.


As the A11 ROM misses a few of the .img files I suddenly had a brainwave and built an install set with the ‘CD-18781Y.201006.099@Teams&Others’ ROM files and the A11 ROM files copied over the top of those. It WORKED!

Something in my install process just didn’t like those missing .img files. This is confirmed on TWO of my devices. I have installed A8.1 on them all, so maybe something has been removed in that process that’s needed. Kind of odd that a stock reinstall didn’t fix the issue though.

Anyway - I’m happy and off to have another go with A11 and voice assist etc.


Could you make quick note about that successful flashing, please? Source for A11 and what did you copy where? It would be very helpful.

dinki / Donny F over on his View Assist GitHub pages with the help of other users has created a guide:

I took the files downloaded from the link (which I already had anyway) and created a new folder, extracted the CD-18781Y.201006.099@Teams&Others image into it and then copied over the A11 image files, replacing any that already exist (most of them).

I used that image folder for the flash although I use Linux (Debian running on a Pi4) for the QFIL/EDL flashing process rather than Windows. IME, Windows can be a nightmare trying to get the USB working (best with USB 2).


@mattmon can you install the splash image and bootanimation retrospectively into A11 do you think? What ADB commands would I need to do this if so?


The power on splash screen is independent of android; just copy splash.bin with the desired orientation to the folder with the rest of your rom files prior to flashing.

You’ll need write access to the system partition to change

Thanks - but what I mean is how to do that after flashing?

You’ll need write access to the system partition to change

@mattmon I’ve had so many problems trying to fix the orientation of the boot animation that I just gave up. How do I determine, after following all your guidelines, that I have write access to the file system? Clearly that’s the issue I’m having. I don’t get any errors, it just simply doesn’t change it. Otherwise, everything is working 100% perfectly fine.

Here’s my current dashboard on my Lenovo’s. I’ve got three of them running currently: