Is this the perfect standalone tablet for HA?

Still not showing up. I suspect the steps I did a few months ago with zdiag, replacing the driver, etc might be the cause. Maybe QFIL is looking for a different device? When I plug it in, it shows up fine in windows devices, and it shows in zdiag. Just not QFIL. I did read somethign about prefering USB 2.0. I will say I’m using a USB 3.0 USB-C USB-C cable, in windows it shows hub#2, port 0004 (or 0006 depending on which plug).

I had terrible problems in windows on a very latest high end system with all USB3.2/4 devices. Couldn’t get it to work at all. I had to use an old windows laptop to test my guide but my preferred way is to use Linux Debian on a Pi4. Rock solid.

I also tried another windows PC and it worked at first but a few days later, same issues and it wouldn’t work. Spent ages on it but no luck. Very frustrating.

So if you do have and old machine, it’s worth a go for sure.

On the windows install, I get all the way to ADB but it doesn’t see any devices. The thinksmart is at “now send the package”.

reboot the device holding down the buttons again and see straight away if you can see it - it times out quickly sometimes

1 Like

I get “failed to open driver control. Permission denied”

Then it says “now send the package”

ADB does not see the device if queried immediately after boot and after the adb get command.

Where does it show that first error - on the PC yes?

no error on the PC. The TS eventually times out. The failed to open error is on the TS

Ah ok - so at this stage the PC isn’t obviously connected or recognised by the device or vice versa. Try closing all the apps on the pc and trying again/ restarting? Bit of a sledgehammer I guess but worth a try. Also re-flashing the recovery again.

Does this screen look normal, except for the errors? The detailed description of how to navigate with the volume buttons doesn’t exactly match the documentation.

IMG_2247 (1)

You didnt load the lineage recovery by the looks. It should have 4 buttons with icons thatll match the directions.


As said in the previous post you’re running the stock recovery not the LOS15 one.
You should repeat the previous phase
That may explains the error you’re facing


Thanks, I’m glad I made an error. Explains why I couldn’t connect with Ubuntu either. Such a nice device for $30.

1 Like

I’ll add a screen shot to the guide to make it clearer :slight_smile:


@janstadt couple of issues. Firstly I can’t seem to figure out how to install Google Play Store. I have Aurora Store installed from the 8.1 ROM but no obvious way to install Google Play Store.

I tried side loading the APK for Webview and it loaded, but still no luck. I also tried downloading Google Chrome from Aurora Store and that worked. Interestingly enough, if I load my home assistant URL in Google Chrome everything works as expected (which gives me a glimmer of hope). Now I just have to figure out why it doesn’t load correctly in Fully Kiosk or HA app. (still get the error that the custom-card doesn’t exist)

Hmmm. It sounds like you havent installed lineage 15 yet. That response was to a question about the newly release lineage install which would replace your android 8.1 rom completely. Follow @pgale 's installation instructions above and install the open gapps via recovery.


@janstadt apologies. I must have confused your reply to my original post (which I’ve quoted below). It seemed logical to me that what you mentioned about the web view APK being missing would explain why my dashboard wasn’t loading on the Lenovo, but worked everywhere else (other tablet and computer)

Success on the Lineage install from Windows and USB3.1. Its an older NUC with unused USB 2 headers, if that could make a difference. The USB cable that finally worked is " Celltronix MCX Titanium 6FT Fast Charging Tangle Free Heavy Duty USB Cable with Type-C Connector. Built to Last! Includes Sync+Charge & Aluminum Tips for Optimum Connectivity".

Perhaps it’s the sync + charge wiring that made it work? My other USB cables failed. On the NUC I was plugged into the orange charging connector, not the blue. Didn’t try the blue.

Is there any reason to update Webview if I’m 100% Fully Kiosk? I assume Fully embeds their own webview. Any tips on using Fully with Lineage?


I found a newer Webview was a few seconds faster to load in some cases. So for that reason I update my devices.

1 Like

I can successfully edit OP, but when I include this link to @pgale’s lineageOS guide, discourse throws the 422 error, attempted from both Firefox and chrome :person_shrugging: