Is this the perfect standalone tablet for HA?

Hello and thx for the answer. Windows was restarted, so was the devcie, i always boot it into the volume down black screen and then let go the button and start doing something with the qfil tool. Is there any step where the vol buttons have to be kept pressed while playing with the qfil?

1 Like

For the partition step and loading of the recovery partition, you need to boot the device holding BOTH volume buttons (+ and -). You said you were booting holding the vol - button.

The buttons only ever need holding while the device boots initially. I hold them until I see the first flash of the logo.

1 Like

Thx, i am doing both buttons, my volume down was meant saying that, just in a short form.
So device is in black screen mode, i can flash/downlaod the said software components as pictured in all steps til step 15. I can repeatedly do that without sahara error, but i am doing this with a usb 3 port.
Logs are saying all success, but after rebooting device into black screen again and selecting the pirt again, the tools section stays only equipped with three items and non of them is anywhere close to partition managaer.
I assume that tools menu is dynamic and changes according to its “findings” on the com port?
Thx alot for any further clues

So, now i got version 2.0.19 instaed of 2.0.0.9 of the qfil tool and all the sudden it shows the partition manager

2 Likes

Ok good. Are you sorted now?

Not sure yet, life got in the way.
When I selected partition manager, it asked if I am sure that I loaded this emmc file (don’t quote me on the name,I dont have the screen in front of me, but it is he file name for the first selectioj field) and I had ok and cancel as options. Selection ok got it fire something error file not found. And that was end of story for my testing today. Will contijiue soon I hope

Lots of people have problems with later USB ports (USB 3+) so that’s the main thing I would try - find a USB 2.0 port if you can and see what happens.

Will do, thx for the quick replies…you guys rock…
Is it typical that it asks for if this file is loaded?

Ok, i am in Lineageos…it was the version of qfil that gave me the issue…
So the package should be updated for future use i guess…
So awesome…
Thx alot

Its not an actual brick is it or just the Lenovo logo on Boot loop.
If that’s the case as Pgale suggests use the Lenovo RSA OR reflash with the original teams firmware from the xda post.

1 Like

That’s great. Can you remember which version of QFIL you were using and what you now have? I think I heard someone else mention similar so would be good to know and add to the guide if necessary.

version that worked is 2.0.1.9
copied into the 084 folder., replacing the old qfil files
looks pretty cool so far. just have to make/copy a good dashboard
any benefit of going towards 099 version of the linage?
di always have to sideload to upload or can i install from lineageos?

v2.0.1.9 is the version included in the ‘ThinkSmartView.zip’ file linked in step 8 - I’m not sure how you had an earlier version unless you already had it installed?

I’ve tried to flash mine as well, but apparently I did something wrong. At this moment the Thinksmart has its ‘origional’ firmware, but I can’t get it any further than the setup menu of ‘Choose a bluetooth device’.
When I try to skip this one, the following message appears:

NOTE
can not find configuration
‘OK’ (button)

I’ve been in a boot menu before with the two volume buttons, but can’t get there anymore. A reset while running (holding both volume buttons for 10s) didn’t help.

Does anybody knows what I can do next?

Which OS are you installing and which guide are you following?

I was using the linageOS, but my guess is I did something wrong with the EDL installation, because it failed something after the connection was made with the Lenovo. Afterwards I saw some errors when I tried to redo the edl guide.
With the raspberry OS it kept giving errors, so today I’ve tried using Ubuntu inside windows (WSL) and that went fine, until I wanted to go to EDL mode.
When I press both volume buttons and turn on the power, the screen stays black (but windows did a bleep for recognition) and when I release them (after more than 20s), it continues with the Lenovo screen and the first setup of language and wifi

Haven’t really been able to resolve and seeing the dropping / reconnecting, but if most users on here aren’t having the issue, then I wonder if it’s something about my setup/configuration… That said, the issue is quite annoying… What are you seeing on your end, @janstadt?

WiFi dropping?

@mattmon did you install Lineage on your devices in the end? Wondering if you have any pointers knowing what you do about Android builds for the WiFi dropping issue a few people are experiencing. Seems it drops after some time when data isn’t being sent. I’ve not had a problem when running Fully Kiosk, probably as the connection is kept alive with constant data streaming, refreshing the dashboard. My guess anyway.

Wonder if we need a new driver or tweaks to the config. Any thoughts?

Yes, WiFi dropping. And my WiFi disconnects occur with FKB running etc, so whatever is the cause for me, it’s not related to whether there is data going back and forth (or not). I’m testing a theory that it has to do with some FKB settings, but need a few days of monitoring to see if I can spot a trend.