Is ZHA the only way to control Aqara Cube from HA?

I recently started acquiring some Aqara devices and so far, I think they are a great value for the money. I started with an E1 Hub and added a couple of motion sensors. Adding them into Home Assistant was a snap - HA automatically found the Hub and connected to it using HomeKit Controller. When I added the 2 motion sensors, they just showed up as devices under the Hub.

However, I just purchased the Aqara Cube. Adding it to the Aqara app was no problem, but it does not show up in HA. I tried to do some reading on this and it seems like most folks integrate the Aqara Cube into HA by having a separate Zigbee controller and using ZHA. Is this the only way? I don’t have a Zigbee controller and I don’t want to get one just for this one device if I do not have to.

Is there a reason motion sensors are automatically added to HA as they are added to Aqara, but the Cube is not? Would love any advice.


Answering you tittle question, the answer is: no, there is also zigbee2mqtt

Based on your description It seems that root cause is in HomeKit. Seems it doesn’t support the Cube. Don’t know if it’s homekit protocol or HomeKit Controller.
Anyway IMO you are doing those things way around. Instead of connecting devices directly to HA, you are using HomeKit Controller as a proxy, which potentially adds to cross-platform incompatibility.

Just as maxym said, I prefer to have a zigbee dongle and connect all zigbee devices directly (with zigbee2mqtt or ZHA) instead of using a hub and a third-party platform.
Zigbee2mqtt is my current approach, with about 15 devices (Aqara sensors, a IKEA tradfri remote and Philips Hue lights) and it works perfect.

Okay - guess I’ll bite the bullet and get a dongle. Thanks for the advice!

1 Like

Dare I ask: how did this work out? I have a combination Z-Wave/Zigbee dongle (Husbzb) and it had the problem of constantly dropping the connection with the Cube (as I recall because it was timing out). So I went and bought the E1 to be sure it would work. And then of course I can’t integrate the Cube with HA because of the lack of HomeKit support. Headache! Anyway, did you find a third party Zigbee hub that worked for you?

Same here, I have a SkyConnect and the connection to my Cubes ist lost using ZHA continously!