Issue Arming Alarm since most recent update with pai (Paradox)

Since the Most recent update when I try to alarm my code using the pai (Paradox) configuration I get the following error: “Failed to call service alarm_control_panel/alarm_arm_away. Validation error: Arming requires a code but none was given for alarm_control_panel.evo192_partition_haus”

I dont know where to add the code is in my configuration just like the example

Here is my configuration:
LOGGING_LEVEL_CONSOLE: 20
LOGGING_LEVEL_FILE: 40
CONNECTION_TYPE: IP
SERIAL_PORT: /dev/ttyUSB0
SERIAL_BAUD: 9600
IP_CONNECTION_HOST: ...*
IP_CONNECTION_PORT: 10000
IP_CONNECTION_PASSWORD: paradox
KEEP_ALIVE_INTERVAL: 10
LIMITS:
zone: auto
user: 1-10
door: “”
pgm: 1-5
partition: auto
module: “”
repeater: “”
keypad: “”
key-switch: “”
SYNC_TIME: true
SYNC_TIME_MIN_DRIFT: 120
PASSWORD: “0000”
MQTT_ENABLE: true
MQTT_HOST: core-mosquitto
MQTT_PORT: 1883
MQTT_KEEPALIVE: 60
MQTT_USERNAME: pai
MQTT_PASSWORD: ***********
MQTT_HOMEASSISTANT_AUTODISCOVERY_ENABLE: true
COMMAND_ALIAS:
arm: partition all arm
disarm: partition all disarm
MQTT_COMMAND_ALIAS:
armed_home: arm_stay
armed_night: arm_sleep
armed_away: arm
disarmed: disarm
HOMEASSISTANT_NOTIFICATIONS_EVENT_FILTERS:

  • live,alarm,-restore
  • trouble,-clock
  • live,tamper
    HOMEASSISTANT_PUBLISH_PARTITION_PROPERTIES:
  • target_state
  • current_state
    HOMEASSISTANT_PUBLISH_ZONE_PROPERTIES:
  • open
  • tamper
    PUSHBULLET_CONTACTS:
    PUSHBULLET_EVENT_FILTERS:
  • live,alarm,-restore
  • trouble,-clock
  • live,tamper
    PUSHOVER_EVENT_FILTERS:
  • live,alarm,-restore
  • trouble,-clock
  • live,tamper
    PUSHOVER_BROADCAST_KEYS:
    SIGNAL_CONTACTS:
    SIGNAL_EVENT_FILTERS:
  • live,alarm,-restore
  • trouble,-clock
  • live,tamper
    GSM_CONTACTS:
    GSM_EVENT_FILTERS:
  • live,alarm,-restore
  • trouble,-clock
  • live,tamper
    IP_INTERFACE_ENABLE: false
    IP_INTERFACE_PASSWORD: paradox
    DUMMY_EVENT_FILTERS:

If I go into Developer tools and manually set up this service with the following this works, but it still doesn’t fix my entities on my homescreen

service: alarm_control_panel.alarm_arm_away
target:
device_id: 6df22efca703fe59a4cced1a9021996b
entity_id: alarm_control_panel.evo192_partition_garage_garten
data:
code: “0”

How could I fix it? Any idea?

Can you see the mqtt commands flying back and forth?

I’ve just run into the same issue.

Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/commands.py:283
integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 11:37:45 PM (3 occurrences)
Last logged: 11:41:51 PM

[547700583888] Arming requires a code but none was given for alarm_control_panel.partition_area_1
[547114658560] Arming requires a code but none was given for alarm_control_panel.partition_area_1

I think it might actually be something with the alarm panel card. Funny enough, dissrm works fine.

Ok solved it for me.

If you click on the alarm widget so that it lists the buttons vertically and then click the gear cog settings, there is a entry field now called default code.

I entered my pass code into that field and now my arming works again.

1 Like

Had the same issue 3 days ago as well, now working with kosmikza’s suggestion. That said, haven’t had any updates to PAI in 2 months, so a bit concerned how the behaviour has changed. Maybe related to HA update?
My IP150 module can’t see the internet, so assuming it’s not related to IP150 firmware changes.

That is great but that option is not available on iOS…

I strongly believe its because of a HA update, ie: they updated that alarm card which constructs the http request from parameters.

Edit the control via the web interface vs the app. Then it should be fine, it just needs to be set once.

Adding the default code does solve the arming problem but it also allows anyone to disarm the system without entering a code. Not desirable in my opinion.

Before I was able to arm without the code but the code was required to disarm.

I just ran into the same issue with Abode running through HomeKit device. It is giving me the same error. Running on MAC or IOS I don’t see anywhere to enter the key code in the web interface? The edit settings has no place for a code.

Same problem homekit aqara G3, even i if insert code.
Last update is a disaster.

Odd, my HA never required the code to arm/disarm before at all.

The issue lies in the card itself, not the actual device. But to get to the setting is a right pain.

On mine, you need to click on the “status” of the card, then click the cog and only then does it show the menu with the option to enter the code.

1 Like

Thanks - will give that a try.

for me with Aqara G3 even if I insert the code into the card, disarming works but not arming

Not familair with Aqara G3? Is that a alarm or a version of HA etc?

it’s a camera with an alarm, connected to homekit, before it worked perfectly.

last update HA solved