Issue Connecting Home Assistant Cloud with Hass.io + RPi3B+

Tags: #<Tag:0x00007f3f183d6fb8>

I should start off by saying that I’m both new to the DIY home automation community and Home Assistant.

My problem, I’m not able to log into Home Assistant Cloud and access HA remotely and/or via the iOS app (current or beta versions).

I recently just installed Hass.io on my Raspberry Pi 3B+. I was able to successfully access the HA dashboard via http://hassio.local:8123 without an issue. However, I’m not able to login to the Home Assistant Cloud. I decided to give this option a try, due to its perceived ease of use. However, when I try logging in via the HA configuration dashboard I receive this error “Unable to reach the Home Assistant Cloud”. And if I go to https://remote.nabucasa.com I receive this error “Connection failed: No response from instance”.

My first thought was to check out the Developer Tools log for any errors. The only I see are:

(1)an error stating something like, “my computer’s IP address just tried unsuccessfully logging in”

(2)"https://aa015h6buqvih86i1.api.met.no/weatherapi/locationforecast/1.9/ returned Cannot connect to host aa015h6buqvih86i1.api.met.no:443 ssl:None [Try again]
12:46 PM main.py (ERROR) - message first occured at 12:30 PM and shows up 2 times”

(3)"Retrying in 20 minutes
12:46 PM components/met/weather.py (ERROR)”

Here’s some additional info about my setup:

(1) My network setup is a TP-link Deco M9 Plus mesh router connected a TP-link Archer modem/router combo setup as a bridge.
(2) My RPi3B+ running Hass.io is plugged into my router (TP-linkDeco M9 Plus) via an Ethernet cable.
(3) The RPi3B+ has a static IP configured via my Deco M9 router.
(4) The only two add-ons I currently have installed on Hass.io are: The Configurator and ESPHome.

If anyone is able to offer any suggestions, advice, or direction; I would greatly appreciate it! I have been running my brain and researching across several blogs without any luck. Right now, I’m not sure if the problem exists within how I’ve configured HA or if it exists with how my internet network is setup.

Thanks!

That looks like it’s probably a DNS or other network connectivity issue. I’d suggest the fastest way of getting this solved is to head over to the Discord chat and ask for help in the #hassio channel there.

Thanks For the direction, Tinkerer. I’ll definitely head over that way!

Did you get this solved Austin? I’m having the same problem

What version of the Hass.io image did you download and install? Is it also on a Pi3?

I have the latest version of hassio and on a rpi b+. But I’m running duckdns and dnsmasq with adguard (which currently not working either) so many settings can be the problem:/

That’s not a version number, “latest” is meaningless.

Version 0.96.2

@AgentClown Hi, I did end up getting everything to work. There was definitely an issue with the network DNS connection. In short, I set a static IP for Hass.io via SSH and then reset my network router to factory defaults and then reconfigured the router’s DNS settings during the initial setup process. After that, everything started working again!