Issue pairing connecting IKEA Styrbar remote to deConz

My setup;
RPi4, docker, Home Assistant supervised
Conbee 2 on a usb-cable
deconz in addons

I open the Phoscon web-interface via Home Assistant, and i successfully added four temp/humidity sensors and six light bulbs.
Then I tried to add the IKEA Styrbar remote

Nothing happens in Phoscon setup switch, Ikea… I have tried both of the two options for IKEA remotes, and the “other” option. I have made sure the remote is functioning by pairing it to two other lights and controlling them.

The stated metod of pairing according to the Phoscon interface is to four times rapidly pressing the button on the inside (backside) of the remote. This doesnt work at all.

The method for pairing the remote to a light bulb is to press and hold the same sync button for 10 seconds in direct contact with the light you want to pair the remote to. This works well.

Any advice on how to succsessfully pair the IKEA Styrbar remote to my Conbee 2?
Best regards

I had also the problem to pair Ikea devices to ConBee II. After trying two different Sticks in my docker environment, with latest firmware (flashed by me). No success. Only one time. But the devices got lost again after i tried to change the setup. I tried for a few days and spend lots of hours. Including disableing bluetooh, wlan etc. pp.

I bought a CC2531 with antenna (USB Cable of course) and moved over to Zigbee2mqtt. Worked without any problems out of the box. Nearly.

1 Like

I experienced more or less the same issue with all my IKEA remotes, although I do not have any experience with the styrbar remote. The IKEA-specific pairing options didn’t work, but I managed to pair them using the “other” option. (I am aware you tried that as well, but you might have done it differently.) I just reset the remote (by quickly pressing the button on the back 4 times), put it close to the deCONZ stick and walk away. After a while deCONZ picks it up and shows it paired the button.

I am not sure if this will always work, but at least it works for me. Keeping the button close to the stick and being patient seems to be quite important. Yes, I’d wish it worked more convenient…

Thanks for sharing your experience!
Found a Cc2531 for 10€ here in Sweden…

Any idea if running two zigbee adapters simultaneously will cause an issue?

Thanks for sharing!!
I will try a couple of hours this weekend and report back the results.

On the same machine? With Zigbee2mqtt? I don’t think that this is possible. But why would one do that anyway?

If you have a good reason i would like to suggest just to setup up everything so that it is fine up and running and save the configuration. After that you may give it a try.

Doublecheck that it has an external Antenna.

Yes. Right now I’m using the deconz and phoscon way. But if that hinders me from pairing a remote i would like to switch to zigbee2mqtt or ZHA… my goal is to make it work. That’s it :joy:

Here is a helpful link (if you did not already see that)

And you do not need two adpaters for one computer :wink:

1 Like

I did try to use ZHA with my conbee stick and pairing IKEA remotes definitely worked better, if not nearly flawless. The only reason why I switched back to deCONZ is that I was unable to pair a remote to a specific bulb (you can of course use automations for that, but I don’t like to do it that way). Maybe that’s solved now. But it is definitely worth trying Z2M / ZHA and look if it works for you!

1 Like

Question; Can I use both the deConz intregration AND the ZHA integration at the same time?
I’m thinking, because I can’t pair my Ikea Styrbar using deConz/Phoscon, maybe I could pair it using the ZHA…?

As far as I know, that’s only possible using a 2nd zigbee stick. The Conbee stick can only be used by one process.

1 Like

No. Any integration (Z2M, ZHA, deCONZ, etc) can only be connected to a single coordinator at a time. Further, running multiple adapters requires maintaining separate Zigbee channels (common channels are 11, 15, 20, and 25) and making sure that your WiFi channels do not bleed into your Zigbee channels.

I still cannot pair the remote with my conbee 2, Phoscon.
This is fubar.

I was able to pair the switch with deconz. I had to reset the factory defaults two or three times before it finally worked (press the pairing button 5 times within 4 seconds) and then pair again - at least 10 seconds for the pairing button.
I am using the ZHA integration.

1 Like

you’re right, works fine