Issue seting up NGINX and DuckDNS on Hassio

Hello everyone,

I’ve been using hassio OS on a raspberry Pi 3B+ for several month, with my setup opened to the internet thanks to DuckDNS (I followed this amazing tutorial : Beginner’s guide to Home Assistant by JuanMTech )
Following a change of internet service provider (from SFR to Orange, in France), I decided to do a fresh start of my whole setup and reinstalled Hassio from the begining. So I watched the new tutorial from JuanMTech : Link to the video

I did everything as he explains, but ended up stuck when setting up NGINX to use hassio outside of my network. Indeed, I did exactly as he said, but in the end I can only access my configuration with at my local IP address, while connected to my home newtork.

I searched in forums, in the discord and github, but I can’t find any answer to my problem.
Do you guys have any idea of what I could be missing or doing wrong ?

More information on what I did below:

Opening the ports of my home network

Setting up a static IP address in Hassio :

Installation of MariaDB:

Setup of NGINX (with SSL and a DuckDNS domain):

Also, because of a recent update, I saw that I should add some lines in configuration.yaml:

But whether I add it or not, the result is the same.

So here is what I see when I try to connect to the domain:

Thank you guys for your help, I hope this is an issue we can fix ! :slight_smile:

if you test your public ip on , is the port open ?

Thank you for your answer.
So I tried to check this IP address on your website : and it showed that:

So I think the port is open, am I right ?

No, that is no test, you need to enter your public ip

Go to , it will show your public ip. Write it down.
Go to

in the red field, enter the ip you just wrote down


Ok, that part is ok.

Do you try or ?

Both of them are not working, with the same error

Better delete the picture above with your port results.

Lets try this:

forward in your router port 8123 to your HA machine, then try again

I deleted the picture, thanks.

Ok so my ports are now:

and this appears when I go to this address :

And if you open a ‘private windows’ (incognito mode) window in your browser ? Better then ?

Well, in fact it doesn’t work (in and out of incognito mode).
I thought it worked but it was an old page in cache
So the message is still:

Ok, might be your router does not support hairpinning. You don’t have a way to test from outside your network ? e.g. a phone on 4G ?

Just tried from my phone in 4G and I have the exact same error (It took too long to respond)

and ?

I have the same error again

Strange. Ports are open, forwarding is done.

one more test

go to , enter (without http:// or https://)

Is it the same IP-address as the one you wrote down earlier ?

Just tried it. Yes it is the same address.

I’m looking into my ISP forum to see if there is a problem with hairpining. Apparently some people have problems with that, but I don’t know if the problem has been fixed.
(I’m in France, the ISP is “Orange”)

Hi everyone,

So I continued my investigation and tried other solutions without success… But, when I tried to connect to the local IP address of my RaspberyPi ( on my file explorer (trying things with SambaShare) Google Chrome opened and displayed this message:

Does anyone understand what it means ? I don’t understand what I should do to set up the host.
Thanks for your help ! I hope we can find a solution soon :slight_smile:

I have a similar issue. I have HASS VM running and Nginx as a docker on Unraid. Not that it should matter.

Nginx can forward to other dockers and my firewall just fine. Now, I have setup the Proxy for Hass, and it gives me the login prompt.


Once I enter username password, it gives me error in connecting.


I have entered following configuration lines to whitelist Nginx proxy IP (internal IP).

  use_x_forwarded_for: true
    - 10.xx.xx.xx  # Add the IP address of the proxy server

Any pointers from here please ?

Try clearing your browser’s cache, or using incognito/private mode in the browser.

I had already tried using a different browser, as well as in private mode on a different browser.
Still getting the error “Unable to connect to Home Assistant”.

Any other ideas please ?