Issue: Sonoff automatically trun on

I have basic sonoff set up as light switch connected to rocker switch on the wall. Everything works fine except when I reboot Hassio by unplugging the power. After Hassio reboots, my sonoff switch turns on automatically. When I look at Home Assistant main page it shows light being turned off. Then After couple of tougle on and off it works fine.

So the question is how can I force that sonoff switch to turn off when my Hassio is forced rebooted by unplugging?

If you’re using tasmota use PowerRetain 1, then the Sonoff will stay in is current state and HA will change to reflect it, think that’s what you’re asking :slight_smile:

Thanks. Everything works properly