Issue to start flicd on

My best guess is that this issue is related to the absence of libc on Alpine Linux. I’ve had the same issue.
If you are interested in a quick and easy fix check out my addon repo. The only dependency is the Bluetooth BCM43xx addon (only for raspberry pis)

i will test it this evening :slight_smile:

Is there a guide for how to install the addon on a regular Hassbian-installation?

  1. Take the Adress:

2.) Integrate it in your Addons:

3.) Install first the Bluethooth Addon:

4.) Install the flicd Addon:

  1. Start the Addon:

6.) Restart the Host and look at the flicd-Log

7.) Press the Flic Button for connect


Thanks @Schmidij_ch ! Finally switched to hassio now.

For people who want to add button to a new install: once the addon is running, keep pressing the flic button to make it connect to another ‘server’.

1 Like

Ok, I installed both the addons above and they report to have started. This is my flicd log:
Available HCI devices found:
Trying hci0
Successfully bound HCI socket
Flic server is now up and running!
Initialization of Bluetooth controller done!

So, how do I get my flic button recognized by the system and how can I find and use the sensor in Home Assistant?

Edit: I got it to work after adding:
template: flic
to my configuration.yaml

Is this correct ?

Don’t you mean: plateform ?

I put it under binary_sensor, like this:

  platform: flic
1 Like

Hi! Have anyone tried this with the new “single press buttons”, i.e. music, lights etc. Would be nice as they are cheeper and better looking in my opinion :D.

I am running the latest version of on a RPi 3 and my flic buttons have both stopped working recently. It is such a long time since I set them up, so I can’t remember what I did. I am using the flicd addon and also have the platform enabled under binary_sensors.

Both buttons only blink red when pressed. I have restarted both the bluetooth bcm43xx addon and the flicd addon and get the following logs:

Flash firmware /lib/firmware/brcm/BCM43430A1.hcd
Set Controller UART speed to 921600 bit/s
Device setup complete

Available HCI devices found:
Trying hci0
hci0 is busy, shutting down and retrying...
Successfully bound HCI socket
Flic server is now up and running!
Initialization of Bluetooth controller done!

What could be wrong here?

After another reboot of one of the buttons work again. The other one (with a lamp icon on it) still doesn’t work.

Sorry to crosspost (found two similar topics, this one was the latest updated)

Anyone able to chip in?

I cannot get my flic buttons to pair no matter how many times I restart the add-on or hassio, nor however long or many times I press them. What is the solution?

Is everything working on the Flic server side?
I’m also having some troubles again. Was looking around if there is an alternative to the server that Flic created, but didn’t find anything. Did notice there’s a recent rewrite of the server, so I’ll be trying that next week. Maybe the Flic integration on HA side needs some love/work.

I agree that the integration may need to be looked at but have no idea how to make that happen. The buttons work fine through Alexa, I just can’t get HA to discover them.

Have you checked HA logs?
Mine “stopped” working for 2 reasons. Battery of flic was dead AND the IP number of the raspberry pi zero where the flic server was running on had changed. Replacing battery and updating IP number in YAML and I’ve got it working again.

I might give it a try to have the Flic integration configured via UI. Never done any real coding in home assistant though.

Some background of how I think flic works:
You have a server running (standalone, or HA addon) that connects with the buttons.
Multiple clients can connect to the server, i.e. Alexa, Home Assistant integration, the simpleclient that comes with the source code
When server reboots, I presume HA integration won’t reconnect automatically, that’s why I sometimes need to restart HA (no option to restart only an integration AFAIK)

The buttons are brand new so not a battery issue. There is nothing I the logs because the buttons have never connected. I can see that the add-on is loaded and working, but that’s where it stops.

Should the host IP be the same as my hassio?

Assuming you’re using HA Addon, you should find the hostname on the add on page.
Just to be sure: you need to press the flic button for 7 to 10 seconds for discovery.
Are these flic 1 or flic 2 buttons? Current integration might only support flic 1. Not sure about that.

edit: localhost host might work, I think you should see something in the logs

Wondering if I can get some advice. The add-on logs look ok:

But the service appears stopped and nothing happens when i click start:

Any advice? Uninstalled and reinstalled several times. Can’t get any flic_click events heard.