Issue with Aqara blind motor E1

I have successfully aded an Aqara E1 blind using the ZHA integration, however I am not able to do anything with it. I get 3 entities added when I add the blind and I cannot operate it. I have removed and re-added the blind and still have the same issue. When I click on the analog_output all I see is NaN, and the other controls do nothing. I have noticed in the entity that the max and minimum for the analog_output is 0, which can’t be right.

Screenshot 2022-06-29 at 14.02.00

1 Like

Hey @kennybb1 I have the exact same problem but the first time I added the device to HA it did actually work using just the analogue input with no NaN on the slider. I could slide the bar to a position and it would set the blind or I could enter a figure between 0 - 100 and it would set the position of the blind based on the % of opening configured on the device. At some point though, it stopped working and I get the NaN error, can’t slide the bar and can’t enter a number in the position field. No idea why it stopped working but pretty sure it was after one of the countless updates HA gets on a regular basis.

Weirdly, it does work on an automation but only on closing (reducing to 0) and not for opening (increasing to 100). I’d like a solution as well as it’s bloody annoying when something works then breaks for no good reason!!!

1 Like

Had a bit of a play around and might have sussed it mate.

Go into Integrations and into the blind controller device in the Zigbee Integration (click devices & select whatever you called it)

Under “Device Info” box, select the three dots next to “Reconfigure Device” and select “Manage Clusters”

Under “Clusters” select “AnalogOutput……” and under “Cluster Attributes” select “Max Present Value”

Change the Value to “100” and ignore the “Manufacturer Override Code” bit.

Click “Set Zigbee Attribute”

When I did all of that, my blind was closed and I suddenly got the slider back in the front end GUI and analogue numerical inputs back!

2 Likes

Amazing! That worked perfectly! Thanks so much for your help! Been having such a hard time for weeks with this!

1 Like

Amazing! Glad I could help. Annoying when something just doesn’t work right isn’t it?

It worked for me too!! thank you! your help was very usefull!

1 Like